summaryrefslogtreecommitdiffstats
path: root/source/ap/acct/acct.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/ap/acct/acct.SlackBuild')
-rwxr-xr-xsource/ap/acct/acct.SlackBuild34
1 files changed, 26 insertions, 8 deletions
diff --git a/source/ap/acct/acct.SlackBuild b/source/ap/acct/acct.SlackBuild
index 510b22a2d..bfdd46fd5 100755
--- a/source/ap/acct/acct.SlackBuild
+++ b/source/ap/acct/acct.SlackBuild
@@ -1,5 +1,5 @@
#!/bin/sh
-# Copyright 2006, 2008, 2009 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2006, 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,11 +21,20 @@
PKGNAM=acct
-PKGVER=6.4-pre1
-VERSION=6.4pre1
-ARCH=${ARCH:-x86_64}
+PKGVER=6.5.4
+VERSION=6.5.4
BUILD=${BUILD:-1}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -48,9 +57,6 @@ cd $TMP
rm -rf ${PKGNAM}-$PKGVER
tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
cd ${PKGNAM}-$PKGVER || exit 1
-zcat $CWD/acct-6.4pre1-6.diff.gz | patch -p1 || exit 1
-cat debian/patches/* | patch -p1
-zcat $CWD/acct.logdir.fhs.diff.gz | patch -p1 || exit 1
# Make sure ownerships and permissions are sane:
chown -R root:root .
@@ -60,6 +66,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+zcat $CWD/acct.logdir.fhs.diff.gz | patch -p1 || exit 1
+# Need this after patching configure.ac:
+autoreconf
+
# Configure:
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -125,9 +135,17 @@ fi
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
- AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
+ AUTHORS COPYING* INSTALL NEWS README TODO \
$PKG/usr/doc/${PKGNAM}-$VERSION
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc