summaryrefslogtreecommitdiffstats
path: root/source/a/unarj/unarj.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/a/unarj/unarj.SlackBuild')
-rwxr-xr-xsource/a/unarj/unarj.SlackBuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/source/a/unarj/unarj.SlackBuild b/source/a/unarj/unarj.SlackBuild
new file mode 100755
index 000000000..56097eb2c
--- /dev/null
+++ b/source/a/unarj/unarj.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+VERSION=265
+ARCH=${ARCH:-x86_64}
+BUILD=${BUILD:-1}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-unarj
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+
+cd $TMP
+rm -rf unarj${VERSION}
+tar xzvf $CWD/unarj${VERSION}.tar.gz
+cd unarj${VERSION}
+chown -R root:root .
+cp -a $CWD/Makefile.gz .
+gzip --force -d Makefile.gz
+make || exit 1
+mkdir -p $PKG/usr/bin
+cat unarj > $PKG/usr/bin/unarj
+chmod 755 $PKG/usr/bin/unarj
+mkdir -p $PKG/usr/doc/unarj${VERSION}
+cp -a \
+ *.txt \
+ $PKG/usr/doc/unarj${VERSION}
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Build the package:
+cd $PKG
+makepkg -l y -c n $TMP/unarj-$VERSION-$ARCH-$BUILD.txz
+