summaryrefslogtreecommitdiffstats
path: root/source/a/infozip/infozip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/a/infozip/infozip.SlackBuild')
-rwxr-xr-xsource/a/infozip/infozip.SlackBuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/source/a/infozip/infozip.SlackBuild b/source/a/infozip/infozip.SlackBuild
new file mode 100755
index 000000000..900c4f95d
--- /dev/null
+++ b/source/a/infozip/infozip.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+VERSION=6.0
+ZIP=3.0
+ARCH=${ARCH:-x86_64}
+BUILD=${BUILD:-1}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-infozip
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+
+cd $TMP
+rm -rf zip$(echo $ZIP | tr -d .)
+tar xvf $CWD/zip$(echo $ZIP | tr -d .).tar.?z* || exit 1
+cd zip$(echo $ZIP | tr -d .)
+chown -R root:root .
+mkdir -p $PKG/usr/doc/zip-$ZIP
+cp -a BUGS CHANGES INSTALL LICENSE README* TODO US* WHATSNEW WHERE \
+ $PKG/usr/doc/zip-$ZIP
+chmod 644 $PKG/usr/doc/zip-$ZIP/*
+make -f unix/Makefile generic_gcc || exit 1
+mkdir -p $PKG/usr/bin
+cat zip > $PKG/usr/bin/zip
+cat zipnote > $PKG/usr/bin/zipnote
+cat zipsplit > $PKG/usr/bin/zipsplit
+cat zipcloak > $PKG/usr/bin/zipcloak
+mkdir -p $PKG/usr/man/man1
+for page in man/zip.1 ; do
+ cat $page | gzip -9c > $PKG/usr/man/man1/$(basename $page).gz
+done
+
+cd $TMP
+rm -rf unzip$(echo $VERSION | tr -d .)
+tar xvf $CWD/unzip$(echo $VERSION | tr -d .).tar.?z* || exit 1
+cd unzip$(echo $VERSION | tr -d .)
+chown -R root:root .
+mkdir -p $PKG/usr/doc/unzip-$VERSION
+cp -a BUGS COPYING* Contents History.* INSTALL LICENSE README ToDo WHERE \
+ $PKG/usr/doc/unzip-$VERSION
+chmod 644 $PKG/usr/doc/unzip-$VERSION/*
+make -f unix/Makefile generic || exit 1
+cat unzip > $PKG/usr/bin/unzip
+cat unzipsfx > $PKG/usr/bin/unzipsfx
+cat funzip > $PKG/usr/bin/funzip
+cat unix/zipgrep > $PKG/usr/bin/zipgrep
+( cd $PKG/usr/bin ; ln -sf unzip zipinfo )
+chmod 755 $PKG/usr/bin/*
+cd man
+for page in funzip.1 unzip.1 unzipsfx.1 zipgrep.1 zipinfo.1 ; do
+ cat $page | gzip -9c > $PKG/usr/man/man1/$page.gz
+done
+cd ..
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Build the package:
+cd $PKG
+makepkg -l y -c n $TMP/infozip-$VERSION-$ARCH-$BUILD.txz
+
+# Clean up the extra stuff:
+if [ "$1" = "--cleanup" ]; then
+ rm -rf $TMP/zip-$ZIP
+ rm -rf $TMP/unzip-$VERSION
+ rm -rf $PKG
+fi