summaryrefslogtreecommitdiffstats
path: root/extra/source/wicd/wicd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'extra/source/wicd/wicd.SlackBuild')
-rwxr-xr-xextra/source/wicd/wicd.SlackBuild36
1 files changed, 24 insertions, 12 deletions
diff --git a/extra/source/wicd/wicd.SlackBuild b/extra/source/wicd/wicd.SlackBuild
index 77c00f464..25fd947e7 100755
--- a/extra/source/wicd/wicd.SlackBuild
+++ b/extra/source/wicd/wicd.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008,2009,2010,2011,2012 Robby Workman Northport, AL, USA
+# Copyright 2008-2015 Robby Workman, Tuscaloosa, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,13 +21,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wicd
-VERSION=${VERSION:-1.7.2.4}
-BUILD=${BUILD:-4}
+VERSION=${VERSION:-1.7.4}
+BUILD=${BUILD:-2}
# Automatically determine architecture for build & packaging:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
@@ -37,7 +37,7 @@ CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PRGNAM
-if [ "$ARCH" = "i486" ]; then
+if [ "$ARCH" = "i586" ]; then
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
LIBDIRSUFFIX=""
@@ -61,20 +61,32 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-zcat $CWD/wicd-1.7.2.4.sanitize.string.bugfix.diff.gz | patch -p1 --verbose || exit 1
+# Bypass the need for pybabel (thanks, dapal!)
+zcat $CWD/manually-compile-translations.diff.gz | patch -p1 || exit 1
+for pofile in $(find po/ -type f -name "*.po") ; do
+ mkdir -p translations/$(basename ${pofile} .po)/LC_MESSAGES
+ msgfmt -o translations/$(basename ${pofile} .po)/LC_MESSAGES/wicd.mo ${pofile}
+done
+
+# wicd-1.7.4 is broken with urwid > 1.0.x, even with this patch.
+# Might be useful someday, but for now since the only thing in Slackware that uses
+# urwid is wicd, just use a 1.0.x version.
+# Thanks to ArchLinux
+#zcat $CWD/wicd-1.7.3-urwid-1.3.0.patch.gz | patch -p0 || exit 1
+
+# Crash fix. Thanks to ArchLinux.
+zcat $CWD/wicd-1421918.patch.gz | patch -p0 || exit 1
+
+# Thanks to Void Linux
+zcat $CWD/curses_bitrate_fix.patch.gz | patch -p0 || exit 1
python setup.py configure \
--lib=/usr/lib${LIBDIRSUFFIX}/wicd \
--kdedir=/usr/share/autostart \
--backends=/usr/lib${LIBDIRSUFFIX}/wicd/backends \
+ --no-install-gnome-shell-extensions \
|| exit 1
-# Bypass the need for pybabel (thanks, dapal!)
-for pofile in $(find po/ -type f -name "*.po") ; do
- mkdir -p translations/$(basename ${pofile} .po)/LC_MESSAGES
- msgfmt -o translations/$(basename ${pofile} .po)/LC_MESSAGES/wicd.mo ${pofile}
-done
-
python setup.py install --root=$PKG || exit 1
# Handle some Slackware defaults