summaryrefslogtreecommitdiffstats
path: root/extra/source/wicd/wicd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'extra/source/wicd/wicd.SlackBuild')
-rwxr-xr-xextra/source/wicd/wicd.SlackBuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/extra/source/wicd/wicd.SlackBuild b/extra/source/wicd/wicd.SlackBuild
index 20dcd393c..77c00f464 100755
--- a/extra/source/wicd/wicd.SlackBuild
+++ b/extra/source/wicd/wicd.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008-2010 Robby Workman Northport, AL, USA
+# Copyright 2008,2009,2010,2011,2012 Robby Workman Northport, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,8 +21,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wicd
-VERSION=${VERSION:-1.7.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.7.2.4}
+BUILD=${BUILD:-4}
# Automatically determine architecture for build & packaging:
if [ -z "$ARCH" ]; then
@@ -51,19 +51,30 @@ rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz || exit 1
cd $PRGNAM-$VERSION || exit 1
+
chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# Fix a couple of bugs that are addressed in the upstream bzr repo
-zcat $CWD/wicd-1.7.0-fix_EAP_fast_typo.diff.gz | patch -p0 --verbose || exit 1
-zcat $CWD/wicd-1.7.0-fix_script_bug.diff.gz | patch -p0 --verbose || exit 1
+zcat $CWD/wicd-1.7.2.4.sanitize.string.bugfix.diff.gz | patch -p1 --verbose || exit 1
python setup.py configure \
--lib=/usr/lib${LIBDIRSUFFIX}/wicd \
--kdedir=/usr/share/autostart \
--backends=/usr/lib${LIBDIRSUFFIX}/wicd/backends \
|| exit 1
+
+# Bypass the need for pybabel (thanks, dapal!)
+for pofile in $(find po/ -type f -name "*.po") ; do
+ mkdir -p translations/$(basename ${pofile} .po)/LC_MESSAGES
+ msgfmt -o translations/$(basename ${pofile} .po)/LC_MESSAGES/wicd.mo ${pofile}
+done
+
python setup.py install --root=$PKG || exit 1
# Handle some Slackware defaults
@@ -75,8 +86,9 @@ dhcp_client = 2
sudo_app = 2
EOF
-# Don't clobber dbus config on upgrade
+# Don't clobber configs on upgrade
mv $PKG/etc/dbus-1/system.d/wicd.conf $PKG/etc/dbus-1/system.d/wicd.conf.new
+mv $PKG/etc/logrotate.d/wicd.logrotate $PKG/etc/logrotate.d/wicd.logrotate.new
mv $PKG/etc/rc.d/rc.wicd $PKG/etc/rc.d/rc.wicd.new
# Compress the man pages and add a bit to the package docs