summaryrefslogtreecommitdiffstats
path: root/extra/source/wicd/wicd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'extra/source/wicd/wicd.SlackBuild')
-rwxr-xr-xextra/source/wicd/wicd.SlackBuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/extra/source/wicd/wicd.SlackBuild b/extra/source/wicd/wicd.SlackBuild
index 21d6d454c..20dcd393c 100755
--- a/extra/source/wicd/wicd.SlackBuild
+++ b/extra/source/wicd/wicd.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008,2009 Robby Workman Northport, AL, USA
+# Copyright 2008-2010 Robby Workman Northport, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,9 +21,17 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wicd
-VERSION=${VERSION:-1.6.2.1}
-ARCH=${ARCH:-x86_64} # This should be the same as the python package
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.7.0}
+BUILD=${BUILD:-2}
+
+# Automatically determine architecture for build & packaging:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
CWD=$(pwd)
TMP=${TMP:-/tmp}
@@ -35,6 +43,8 @@ elif [ "$ARCH" = "s390" ]; then
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
fi
rm -rf $PKG
@@ -45,11 +55,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
+# Fix a couple of bugs that are addressed in the upstream bzr repo
+zcat $CWD/wicd-1.7.0-fix_EAP_fast_typo.diff.gz | patch -p0 --verbose || exit 1
+zcat $CWD/wicd-1.7.0-fix_script_bug.diff.gz | patch -p0 --verbose || exit 1
+
python setup.py configure \
--lib=/usr/lib${LIBDIRSUFFIX}/wicd \
--kdedir=/usr/share/autostart \
--backends=/usr/lib${LIBDIRSUFFIX}/wicd/backends \
- --wicdgroup=netdev \
|| exit 1
python setup.py install --root=$PKG || exit 1