summaryrefslogtreecommitdiffstats
path: root/extra/source/pure-alsa-system/xfce4-mixer/xfce4-mixer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xextra/source/pure-alsa-system/xfce4-mixer/xfce4-mixer.SlackBuild (renamed from pasture/source/xfce4-mixer/xfce4-mixer.SlackBuild)26
1 files changed, 18 insertions, 8 deletions
diff --git a/pasture/source/xfce4-mixer/xfce4-mixer.SlackBuild b/extra/source/pure-alsa-system/xfce4-mixer/xfce4-mixer.SlackBuild
index 8d383e4a1..9e38cdb0e 100755
--- a/pasture/source/xfce4-mixer/xfce4-mixer.SlackBuild
+++ b/extra/source/pure-alsa-system/xfce4-mixer/xfce4-mixer.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for xfce4-mixer
# Copyright 2010, 2011 Robby Workman, Northport, Alabama, USA
+# Copyright 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,9 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PKGNAM=xfce4-mixer
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1_alsa}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,6 @@ fi
NUMJOBS=${NUMJOBS:-" -j7 "}
-CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
@@ -54,11 +56,19 @@ else
LIBDIRSUFFIX=""
fi
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
-tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
+tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
@@ -67,9 +77,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p1 < $CWD/0001-Make-Unique-support-optional.patch
-patch -p1 < $CWD/0001-Use-datadir-xfce4-mixer-as-MIXER_DATADIR.patch
-patch -p1 < $CWD/0001-icons-Makefile.am-Remove-unnecessary-gtk-update-icon.patch
+zcat $CWD/0001-Make-Unique-support-optional.patch | patch -p1 --verbose || exit 1
+zcat $CWD/0001-Use-datadir-xfce4-mixer-as-MIXER_DATADIR.patch | patch -p1 --verbose || exit 1
+zcat $CWD/0001-icons-Makefile.am-Remove-unnecessary-gtk-update-icon.patch | patch -p1 --verbose || exit 1
xdt-autogen