summaryrefslogtreecommitdiffstats
path: root/extra/source/partitionmanager/partitionmanager.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'extra/source/partitionmanager/partitionmanager.SlackBuild')
-rwxr-xr-xextra/source/partitionmanager/partitionmanager.SlackBuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/extra/source/partitionmanager/partitionmanager.SlackBuild b/extra/source/partitionmanager/partitionmanager.SlackBuild
index cf91510f1..371ef22ff 100755
--- a/extra/source/partitionmanager/partitionmanager.SlackBuild
+++ b/extra/source/partitionmanager/partitionmanager.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2009 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
# Redistribution and use of this script, with or without modification, is
@@ -20,9 +20,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-VERSION=1.0.0-BETA1
-ARCH=${ARCH:-x86_64}
+VERSION=1.0.2
BUILD=${BUILD:-1}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
NUMJOBS=${NUMJOBS:--j6}
CWD=$(pwd)
@@ -38,18 +48,23 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf partitionmanager-$VERSION
-tar xvf $CWD/partitionmanager-$VERSION.tar.bz2 || exit 1
+tar xvf $CWD/partitionmanager-$VERSION.tar.?z* || exit 1
cd partitionmanager-$VERSION || exit 1
-# All the rest of KDE uses 'en' not 'en_US' as a documentation language:
-mv doc/{en_US,en} || exit 1
-sed -i -e 's/en_US/en/' doc/CMakeLists.txt
-sed -i -e 's/en_US/en/' doc/en/CMakeLists.txt
+
+## All the rest of KDE uses 'en' not 'en_US' as a documentation language:
+#mv doc/{en_US,en} || exit 1
+#sed -i -e 's/en_US/en/' doc/CMakeLists.txt
+#sed -i -e 's/en_US/en/' doc/en/CMakeLists.txt
+
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \