summaryrefslogtreecommitdiffstats
path: root/testing/source/linux-5.19.x/kernel-modules.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2022-08-17 20:41:53 +0000
committer Eric Hameleers <alien@slackware.com>2022-08-18 07:00:13 +0200
commit353496a7b2d983d3facb95253b0b22dd7ae224e6 (patch)
tree9a12695b4e7d71b11ad84218bdedf7214ad116d0 /testing/source/linux-5.19.x/kernel-modules.SlackBuild
parentacedcf0daaa711f242744ca6577aeb42717a44d5 (diff)
downloadcurrent-353496a7b2d983d3facb95253b0b22dd7ae224e6.tar.gz
current-353496a7b2d983d3facb95253b0b22dd7ae224e6.tar.xz
Wed Aug 17 20:41:53 UTC 202220220817204153
a/aaa_glibc-solibs-2.36-x86_64-2.txz: Rebuilt. a/kernel-generic-5.19.2-x86_64-1.txz: Upgraded. a/kernel-huge-5.19.2-x86_64-1.txz: Upgraded. a/kernel-modules-5.19.2-x86_64-1.txz: Upgraded. ap/vim-9.0.0223-x86_64-1.txz: Upgraded. Fix use after free, out-of-bounds read, and heap based buffer overflow. Thanks to marav for the heads-up. For more information, see: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2816 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2817 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2819 (* Security fix *) d/kernel-headers-5.19.2-x86-1.txz: Upgraded. k/kernel-source-5.19.2-noarch-1.txz: Upgraded. l/glibc-2.36-x86_64-2.txz: Rebuilt. Rebuilt with a patch from Arch to reenable DT_HASH in shared objects since the change broke Steam games that use EPIC's EAC. I'm not exactly 100% on board with this approach, but since DT_GNU_HASH remains and is still used, I guess I'll go along with it for now. Hopefully EAC will be patched and we can back this out. Thanks to Swaggajackin for the notice and for providing links to the glibc bug discussion as well as the patch. If anything else needs a rebuild after this, let me know in the LQ thread. l/glibc-i18n-2.36-x86_64-2.txz: Rebuilt. l/glibc-profile-2.36-x86_64-2.txz: Rebuilt. xap/vim-gvim-9.0.0223-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'testing/source/linux-5.19.x/kernel-modules.SlackBuild')
-rwxr-xr-xtesting/source/linux-5.19.x/kernel-modules.SlackBuild146
1 files changed, 0 insertions, 146 deletions
diff --git a/testing/source/linux-5.19.x/kernel-modules.SlackBuild b/testing/source/linux-5.19.x/kernel-modules.SlackBuild
deleted file mode 100755
index ff083c16a..000000000
--- a/testing/source/linux-5.19.x/kernel-modules.SlackBuild
+++ /dev/null
@@ -1,146 +0,0 @@
-#!/bin/sh
-
-# Copyright 2018, 2020, 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# To use this script, point it to a Linux kernel source tree and a .config
-# file by setting the appropriate environment variables:
-#
-# KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild
-#
-# By default, it will use the source and .config already in /usr/src/linux (if possible).
-
-# KERNEL_NAME is optional, and we don't use it. Define it to "-name" if
-# you'd like an extra string after "kernel" in the package name
-# (i.e. "kernel-name-modules").
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-KERNEL_NAME=${KERNEL_NAME:-}
-KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
-KERNEL_CONFIG=${KERNEL_CONFIG:-/usr/src/linux/.config}
-BUILD=${BUILD:-1}
-
-# The CONFIG_DEBUG_INFO_BTF_MODULES option adds a huge amount of debugging
-# data to the modules which we don't actually need. We'll strip debugging
-# information from kernel modules by default. If you are building a debug
-# kernel and wish to retain this data, export the variable below set to "NO".
-STRIP_DEBUG=${STRIP_DEBUG:-YES}
-
-if [ ! -r "${KERNEL_CONFIG}" ]; then
- echo "Error: the KERNEL_CONFIG environment variable needs to be set to the"
- echo ".config file to be used to build these modules. Example:"
- echo "KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild"
- exit 1
-fi
-if [ ! -d "${KERNEL_SOURCE}" ]; then
- echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
- exit 1
-fi
-# Get the kernel version from the kernel Makefile:
-VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
-# Set LOCALVERSION to the value found inside the .config:
-LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- # We will need to copy the config and run make oldconfig and make
- # prepare in order to generate kernel/bounds.s, where we can find
- # the true $PACKAGE_ARCH.
- if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
- cp -a ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
- fi
- cd ${KERNEL_SOURCE}
- make oldconfig 1> /dev/null 2> /dev/null
- make prepare 1> /dev/null 2> /dev/null
- PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
- echo "kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz"
- exit 0
-fi
-
-NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-kernel${KERNEL_NAME}-modules
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-
-# Set the variable $KERNEL_CLEAN to anything to run "make clean" before the
-# build. Default is to start compiling in the tree as we found it.
-if [ ! -z "${KERNEL_CLEAN}" ]; then
- ( cd ${KERNEL_SOURCE}
- echo "Cleaning kernel source (make clean)..."
- make clean
- # Make sure header files aren't missing...
- make prepare
- # Don't package the kernel in the sources:
- find . -name "*Image" -exec rm "{}" \+
- # No need for these:
- rm -f .config.old .version
- find . -name "*.cmd" -exec rm -f "{}" \+
- rm .*.d
- )
-fi
-
-# Copy the .config into the kernel source directory (unless it's there already)
-if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
- echo "Copying the .config file to the kernel source tree:"
- cp -a --verbose ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
-fi
-
-( cd ${KERNEL_SOURCE}
- echo "Running make oldconfig..."
- make oldconfig
- echo "Running a preliminary make (needed to create modules.builtin.modinfo)..."
- make $NUMJOBS || exit 1
- echo "Building kernel modules..."
- make $NUMJOBS modules || exit 1
- echo "Installing kernel modules to $PKG..."
- make INSTALL_MOD_PATH=$PKG modules_install || exit 1
- if [ "$STRIP_DEBUG" = "YES" ]; then
- echo "Stripping debug info from kernel modules..."
- find $PKG -name "*.ko" -exec strip --strip-debug "{}" \;
- fi
- # Fix build and source symlinks if they are pointing into /tmp:
- ( cd $PKG/lib/modules/${VERSION}${LOCALVERSION}
- for symlink in build source ; do
- target=$(readlink $symlink)
- if echo $target | grep -q "^/tmp/package-kernel-source/" ; then
- rm -f $symlink
- ln -sf $(echo $target | sed "s|/tmp/package-kernel-source/|/|g") $symlink
- fi
- done
- )
- depmod -b $PKG -a ${VERSION}${LOCALVERSION}
-) || exit 1
-
-mkdir $PKG/install
-cat $CWD/slack-desc/slack-desc.kernel-modules-template | sed "s/%PACKAGE_NAME%/kernel${KERNEL_NAME}-modules${LOCALVERSION}/g" > $PKG/install/slack-desc
-
-# Fetch the kernel architecture from the source tree:
-cd ${KERNEL_SOURCE}
-PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
-
-# Make the package:
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz
-