summaryrefslogtreecommitdiffstats
path: root/testing/source/linux-5.14.x/kernel-headers.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2021-10-28 01:11:07 +0000
committer Eric Hameleers <alien@slackware.com>2021-10-28 15:00:27 +0200
commite2c76f9da884cde16347144d21d387e7558a3253 (patch)
tree63d1c875a5dbb4d12dc5493e1db8e52575dd2888 /testing/source/linux-5.14.x/kernel-headers.SlackBuild
parent77efb8f5d9d940e32f8ff28f474d273d21661029 (diff)
downloadcurrent-e2c76f9da884cde16347144d21d387e7558a3253.tar.gz
current-e2c76f9da884cde16347144d21d387e7558a3253.tar.xz
Thu Oct 28 01:11:07 UTC 202120211028011107
a/kernel-generic-5.14.15-x86_64-1.txz: Upgraded. a/kernel-huge-5.14.15-x86_64-1.txz: Upgraded. a/kernel-modules-5.14.15-x86_64-1.txz: Upgraded. d/cmake-3.21.4-x86_64-1.txz: Upgraded. d/kernel-headers-5.14.15-x86-1.txz: Upgraded. k/kernel-source-5.14.15-noarch-1.txz: Upgraded. We're going to go ahead and take both of those changes that were considered in /testing. GazL almost had me talked out of the autogroup change, but it's easy to disable if traditional "nice" behavior is important to someone. -DRM_I810 n -INLINE_READ_UNLOCK y -INLINE_READ_UNLOCK_IRQ y -INLINE_SPIN_UNLOCK_IRQ y -INLINE_WRITE_UNLOCK y -INLINE_WRITE_UNLOCK_IRQ y PREEMPT n -> y PREEMPT_VOLUNTARY y -> n SCHED_AUTOGROUP n -> y +CEC_GPIO n +DEBUG_PREEMPT y +PREEMPTION y +PREEMPT_COUNT y +PREEMPT_DYNAMIC y +PREEMPT_RCU y +PREEMPT_TRACER n +RCU_BOOST n +TASKS_RCU y +UNINLINE_SPIN_UNLOCK y kde/plasma-desktop-5.23.2.1-x86_64-1.txz: Upgraded. l/imagemagick-7.1.0_12-x86_64-1.txz: Upgraded. l/librsvg-2.52.3-x86_64-1.txz: Upgraded. n/bind-9.16.22-x86_64-1.txz: Upgraded. This update fixes bugs and the following security issue: The "lame-ttl" option is now forcibly set to 0. This effectively disables the lame server cache, as it could previously be abused by an attacker to significantly degrade resolver performance. For more information, see: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-25219 (* Security fix *) n/c-ares-1.18.1-x86_64-1.txz: Upgraded. n/samba-4.15.1-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'testing/source/linux-5.14.x/kernel-headers.SlackBuild')
-rwxr-xr-xtesting/source/linux-5.14.x/kernel-headers.SlackBuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/testing/source/linux-5.14.x/kernel-headers.SlackBuild b/testing/source/linux-5.14.x/kernel-headers.SlackBuild
deleted file mode 100755
index 2721350a1..000000000
--- a/testing/source/linux-5.14.x/kernel-headers.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Copyright 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# To use this script, point it to a Linux kernel source tree, and it will make
-# the kernel-headers package using the .config to get all needed package
-# version information:
-#
-# KERNEL_SOURCE=/usr/src/linux ./kernel-headers.SlackBuild
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PKGNAM=${PKGNAM:-kernel-headers}
-BUILD=${BUILD:-1}
-KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
-if [ -z "${HEADERS_ARCH}" ]; then
- case "$(uname -m)" in
- i?86) HEADERS_ARCH=x86 ;;
- x86_64) HEADERS_ARCH=x86 ;;
- # Use uname -m for all other archs:
- *) HEADERS_ARCH=$(uname -m) ;;
- esac
-fi
-if [ ! -d "${KERNEL_SOURCE}" ]; then
- echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
- exit 1
-elif [ ! -r ${KERNEL_SOURCE}/.config ]; then
- echo "Error: a .config was not found in ${KERNEL_SOURCE}."
- exit 1
-fi
-# Get the kernel version from the kernel Makefile:
-VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
-# Set LOCALVERSION to the value found inside the .config:
-LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
-
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-$PKGNAM
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz"
- exit 0
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-mkdir -p $PKG/usr
-
-# Generate the kernel headers and clean them up:
-( cd ${KERNEL_SOURCE}
- echo "Generating headers from the Linux kernel source tree in ${KERNEL_SOURCE}:"
- make headers_install ARCH=${HEADERS_ARCH} INSTALL_HDR_PATH=$PKG/usr
- cd $PKG/usr/include
- # You won't want these files. The ones in libdrm work better.
- rm -rf drm
- # This next part seems pretty much cosmetic, but since we've been doing this
- # for a long time (and others also do), we'll stick with it:
- mv asm asm-${HEADERS_ARCH}
- ln -sf asm-${HEADERS_ARCH} asm
- # Remove unneeded dotfiles:
- find . -name ".??*" -exec rm -f {} \+
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc/slack-desc.kernel-headers > $PKG/install/slack-desc
-
-# Make the package:
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz
-