summaryrefslogtreecommitdiffstats
path: root/source/n/pssh/pssh.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2011-04-25 13:37:00 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 22:45:18 +0200
commit75a4a592e5ccda30715f93563d741b83e0dcf39e (patch)
tree502f745607e77a2c4386ad38d818ddcafe81489c /source/n/pssh/pssh.SlackBuild
parentb76270bf9e6dd375e495fec92140a79a79415d27 (diff)
downloadcurrent-75a4a592e5ccda30715f93563d741b83e0dcf39e.tar.gz
current-75a4a592e5ccda30715f93563d741b83e0dcf39e.tar.xz
Slackware 13.37slackware-13.37
Mon Apr 25 13:37:00 UTC 2011 Slackware 13.37 x86_64 stable is released! Thanks to everyone who pitched in on this release: the Slackware team, the folks producing upstream code, and linuxquestions.org for providing a great forum for collaboration and testing. The ISOs are off to be replicated, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. Please consider supporting the Slackware project by picking up a copy from store.slackware.com. We're taking pre-orders now, and offer a discount if you sign up for a subscription. As always, thanks to the Slackware community for testing, suggestions, and feedback. :-) Have fun!
Diffstat (limited to 'source/n/pssh/pssh.SlackBuild')
-rwxr-xr-xsource/n/pssh/pssh.SlackBuild39
1 files changed, 21 insertions, 18 deletions
diff --git a/source/n/pssh/pssh.SlackBuild b/source/n/pssh/pssh.SlackBuild
index 25c19ae3c..d0870d785 100755
--- a/source/n/pssh/pssh.SlackBuild
+++ b/source/n/pssh/pssh.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,9 @@
# required: package "python" version 2.2 or higher installed
-VERSION=2.1.1
+VERSION=2.2
BUILD=1
-# Note that the package will be created as 'noarch' !
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -61,34 +60,38 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-for binary in bin/* ; do
- # Fix an error from the author
- sed -r "s|basedir\)|basedir + \"/lib${LIBDIRSUFFIX}\")|" \
- < $binary > $binary.tmp
- cp $binary.tmp $binary
- rm -f $binary.tmp
-done
-
-mkdir -p $PKG/$PREFIX/bin
-cp -a bin/* $PKG/$PREFIX/bin/.
-
for library in psshlib/* ; do
# This will force removepkg to remove all runtime-compiled *.pyc files
touch ${library}c
done
-mkdir -p $PKG/$PREFIX/lib${LIBDIRSUFFIX}
-cp -a psshlib $PKG/$PREFIX/lib${LIBDIRSUFFIX}/.
+# Install:
+python setup.py build install --root=$PKG
+
+# Compress manual pages:
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do
+ ln -s $( readlink $i ).gz $i.gz
+ rm $i
+done
mkdir -p $PKG/$PREFIX/doc/pssh-$VERSION
cp -a \
- AUTHORS BUGS COPYING ChangeLog INSTALL PKG-INFO TODO \
+ AUTHORS BUGS COPYING* INSTALL PKG-INFO README* TODO \
doc/pssh*html $PKG/$PREFIX/doc/pssh-$VERSION/.
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
# Build package:
cd $PKG
-/sbin/makepkg -l y -c n $TMP/pssh-$VERSION-noarch-$BUILD.txz
+/sbin/makepkg -l y -c n $TMP/pssh-$VERSION-$ARCH-$BUILD.txz