summaryrefslogtreecommitdiffstats
path: root/source/n/pssh/pssh.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-08-09 18:35:29 +0000
committer Eric Hameleers <alien@slackware.com>2020-08-10 08:59:55 +0200
commit3fb3209629a8c0403ef7080d1c6e730cd9c4c659 (patch)
tree00fd87a7ab2804219468c17685b52ff6335a51c6 /source/n/pssh/pssh.SlackBuild
parentdd1713b41604e62761d3ddf3f51edff078028efe (diff)
downloadcurrent-3fb3209629a8c0403ef7080d1c6e730cd9c4c659.tar.gz
current-3fb3209629a8c0403ef7080d1c6e730cd9c4c659.tar.xz
Sun Aug 9 18:35:29 UTC 202020200809183529
a/kernel-firmware-20200807_c331aa9-noarch-1.txz: Upgraded. d/check-0.15.2-x86_64-1.txz: Upgraded. d/doxygen-1.8.19-x86_64-1.txz: Upgraded. d/re2c-2.0.2-x86_64-1.txz: Upgraded. d/strace-5.8-x86_64-1.txz: Upgraded. l/fuse3-3.9.3-x86_64-1.txz: Upgraded. l/imagemagick-7.0.10_26-x86_64-1.txz: Upgraded. n/iproute2-5.8.0-x86_64-1.txz: Upgraded. n/pssh-2.3.4-x86_64-1.txz: Upgraded. n/rsync-3.2.3-x86_64-1.txz: Upgraded. x/font-alias-1.0.4-noarch-1.txz: Upgraded. x/font-misc-ethiopic-1.0.4-noarch-1.txz: Upgraded.
Diffstat (limited to 'source/n/pssh/pssh.SlackBuild')
-rwxr-xr-xsource/n/pssh/pssh.SlackBuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/source/n/pssh/pssh.SlackBuild b/source/n/pssh/pssh.SlackBuild
index e199c3e72..c54131830 100755
--- a/source/n/pssh/pssh.SlackBuild
+++ b/source/n/pssh/pssh.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2010, 2011, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=pssh
-VERSION=${VERSION:-$(echo pssh*.tar.gz | cut -d - -f 2 | rev | cut -f 3- -d . | rev)}
-BUILD=${BUILD:-5}
+VERSION=${VERSION:-$(echo pssh*.tar.?z | cut -d - -f 2 | rev | cut -f 3- -d . | rev)}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -61,7 +61,7 @@ mkdir -p $TMP $PKG
cd $TMP
rm -rf pssh-$VERSION
-tar xvf $CWD/pssh-$VERSION.tar.gz || exit 1
+tar xvf $CWD/pssh-$VERSION.tar.?z || exit 1
cd pssh-$VERSION || exit 1
chown -R root:root .
find . \
@@ -70,16 +70,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# fix python3 issues
-zcat $CWD/pssh-2.3.1-py3-import.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/pssh-2.3.1-py3-min-int-none.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/pssh-2.3.1-py3-non-blocking.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/pssh-2.3.1-py3-str-bytes-encode.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/pssh-read-stdin-as-bytes-in-Python-3.patch.gz | patch -p1 --verbose || exit 1
-
# Install
python3 setup.py build install --root=$PKG
+# Relocate man pages:
+mv $PKG/usr/share/man $PKG/usr
+rmdir $PKG/usr/share 2> /dev/null
+
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
@@ -89,7 +86,7 @@ done
mkdir -p $PKG/$PREFIX/doc/pssh-$VERSION
cp -a \
- AUTHORS BUGS COPYING* INSTALL PKG-INFO README* TODO \
+ AUTHORS* BUGS* COPYING* INSTALL* PKG-INFO* README* TODO* \
doc/pssh*html $PKG/$PREFIX/doc/pssh-$VERSION/.
# If there's a ChangeLog, installing at least part of the recent history