summaryrefslogtreecommitdiffstats
path: root/source/n/netatalk/netatalk.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2018-06-27 04:13:25 +0000
committer Eric Hameleers <alien@slackware.com>2018-06-27 21:00:55 +0200
commit63f56cc135f65b25d924c16f959a8819e55740d9 (patch)
treef7508feb75b8a6f230f61b50ef94ff16b9d69f49 /source/n/netatalk/netatalk.SlackBuild
parent2a8b2eba309a73a177e79a88be0b024f642cc350 (diff)
downloadcurrent-bd158a154a93ab400a28cd42815a1524d51d6f58.tar.gz
current-bd158a154a93ab400a28cd42815a1524d51d6f58.tar.xz
Wed Jun 27 04:13:25 UTC 201820180627041325
a/kernel-generic-4.14.52-x86_64-1.txz: Upgraded. a/kernel-huge-4.14.52-x86_64-1.txz: Upgraded. a/kernel-modules-4.14.52-x86_64-1.txz: Upgraded. ap/sox-14.4.2-x86_64-6.txz: Rebuilt. Rebuilt to drop libssp dependency. We're no longer building that with gcc since glibc already includes a built-in SSP implementation. d/gcc-8.1.1-x86_64-1.txz: Upgraded. Shared library .so-version bump. This is taken from the gcc-8-branch of the svn repo on 20180626, revision r262159. All packages have been tested for build failures and all new FTBFS issues are fixed - I think we're down to the six possibly obsolete X drivers (geode, r128, s3virge, savage, sis, and tseng) and virtuoso-ose. d/gcc-brig-8.1.1-x86_64-1.txz: Upgraded. d/gcc-g++-8.1.1-x86_64-1.txz: Upgraded. d/gcc-gfortran-8.1.1-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/gcc-gnat-8.1.1-x86_64-1.txz: Upgraded. d/gcc-go-8.1.1-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/gcc-objc-8.1.1-x86_64-1.txz: Upgraded. d/kernel-headers-4.14.52-x86-1.txz: Upgraded. d/libtool-2.4.6-x86_64-8.txz: Rebuilt. Recompiled to update embedded GCC version number. k/kernel-source-4.14.52-noarch-1.txz: Upgraded. l/db48-4.8.30-x86_64-4.txz: Rebuilt. Patched to fix a symbol collision with gcc8. n/netatalk-3.1.11-x86_64-1.txz: Upgraded. Thanks to Matthew Schumacher for updating the build script and providing some useful config file examples. extra/pure-alsa-system/sox-14.4.2-x86_64-6_alsa.txz: Rebuilt. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'source/n/netatalk/netatalk.SlackBuild')
-rwxr-xr-xsource/n/netatalk/netatalk.SlackBuild56
1 files changed, 25 insertions, 31 deletions
diff --git a/source/n/netatalk/netatalk.SlackBuild b/source/n/netatalk/netatalk.SlackBuild
index 8a8858016..679cdb76e 100755
--- a/source/n/netatalk/netatalk.SlackBuild
+++ b/source/n/netatalk/netatalk.SlackBuild
@@ -19,12 +19,14 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Script updated to package netatalk 3.1.11 by Matthew Schumacher
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=netatalk
VERSION=${VERSION:-$(echo netatalk-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-7}
+BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j7 "}
@@ -76,42 +78,44 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fixup some paths in etc2ps.sh
-zcat $CWD/netatalk.etc2ps.diff.gz | patch -p1 || exit 1
-
-autoreconf -vif
+# use the system libevent, because the internal one won't compile
+# with openssl 1.1. Also skip pam and kerberos (for now).
CFLAGS="$SLKCFLAGS" \
-CPPFLAGS="-D_IPP_PRIVATE_STRUCTURES" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
- --sysconfdir=/etc \
+ --sysconfdir=/etc/netatalk \
--libexecdir=/usr/sbin \
--localstatedir=/var \
--disable-static \
--with-shadow \
- --enable-ddp \
+ --disable-static \
+ --with-libevent=system \
+ --with-dbus-sysconf-dir=/etc/dbus-1/system.d/ \
+ --with-dbus-daemon=/usr/bin/dbus-daemon \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
+# At least make this unreadable to non-root users:
+if [ -u $PKG/usr/bin/afppasswd ]; then
+ chmod 4711 $PKG/usr/bin/afppasswd
+fi
+
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-gzip -9 $PKG/usr/man/man?/*
-
-# This is normally installed setuid root, but I'm not 100% sure I trust it yet.
-# I see it uses strcpy() in a few places...
-chmod 755 $PKG/usr/bin/afppasswd
-
-# Install the afppasswd config file
-mkdir -p $PKG/etc/netatalk
-cat $CWD/afppasswd > $PKG/etc/netatalk/afppasswd
+# Compress manual pages:
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do
+ ln -s $( readlink $i ).gz $i.gz
+ rm $i
+done
# Install an init script
mkdir -p $PKG/etc/rc.d
@@ -123,28 +127,18 @@ zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
( cd $PKG/etc/netatalk
- for file in AppleVolumes.default AppleVolumes.system afpd.conf afp_ldap.conf afppasswd atalkd.conf netatalk.conf papd.conf ; do
+ for file in afp.conf dbus-session.conf extmap.conf ; do
mv $file ${file}.new
done
)
mkdir -p $PKG/usr/doc/netatalk-$VERSION
cp -a \
- CONTRIBUTORS COPYING COPYRIGHT NEWS README TODO VERSION doc/* \
+ AUTHORS CONTRIBUTORS COPYING* COPYRIGHT NEWS VERSION \
$PKG/usr/doc/netatalk-$VERSION
-# -1, Redundant
-rm -rf $PKG/usr/doc/netatalk-$VERSION/doc/Makefile* \
- $PKG/usr/doc/netatalk-$VERSION/doc/htmldocs \
- $PKG/usr/doc/netatalk-$VERSION/doc/*.pdf
-
-# "make install" creates this directory with chmod 0777
-# I'd rather use 755, but I'll assume since this is a
-# new directory that it is needed for something. This
-# will help it a bit anyway...
-chmod 1777 $PKG/var/spool/netatalk
-# If anyone can confirm that 755 would still work let me know.
+cp -a $CWD/examples $PKG/usr/doc/netatalk-$VERSION
+chown -R root:root $PKG/usr/doc/netatalk-$VERSION/examples
# Build the package:
cd $PKG
/sbin/makepkg -l y -c n $TMP/netatalk-$VERSION-$ARCH-$BUILD.txz
-