summaryrefslogtreecommitdiffstats
path: root/source/l/python-doxypypy/python-doxypypy.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2021-11-22 19:52:11 +0000
committer Eric Hameleers <alien@slackware.com>2021-11-23 08:59:58 +0100
commitef001ab523d0969f0fe72336a66798bae8fed36f (patch)
tree801ade9a35dbbfcc5dd3846a11f79b6ade3cc3c3 /source/l/python-doxypypy/python-doxypypy.SlackBuild
parent47129ed59f756b223eb47e3b28088900ad63e21c (diff)
downloadcurrent-ef001ab523d0969f0fe72336a66798bae8fed36f.tar.gz
current-ef001ab523d0969f0fe72336a66798bae8fed36f.tar.xz
Mon Nov 22 19:52:11 UTC 202120211122195211
l/imagemagick-7.1.0_16-x86_64-1.txz: Upgraded. l/python-Jinja2-3.0.3-x86_64-1.txz: Added. Added missing dependency of kapidox. l/python-MarkupSafe-2.0.1-x86_64-1.txz: Added. Added missing dependency of Mako. l/python-PyYAML-6.0-x86_64-1.txz: Added. Added missing dependency of kapidox. l/python-doxypypy-0.8.8.6-x86_64-1.txz: Added. Added missing dependency of kapidox. l/python-doxyqml-0.5.1-x86_64-1.txz: Added. Added missing dependency of kapidox. l/python-pbr-5.8.0-x86_64-1.txz: Added. Added missing dependency of python-pysol_cards. extra/tigervnc/tigervnc-1.12.0-x86_64-2.txz: Rebuilt. Use the upstream vncserver script, patched to search in some additional locations for a startup script: $HOME/.vnc/xstartup, $HOME/.xinitrc, and /etc/X11/xinit/xinitrc. Add a symlink for vncserver in the old location (/usr/bin/vncserver). Thanks to 0XBF.
Diffstat (limited to 'source/l/python-doxypypy/python-doxypypy.SlackBuild')
-rwxr-xr-xsource/l/python-doxypypy/python-doxypypy.SlackBuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/source/l/python-doxypypy/python-doxypypy.SlackBuild b/source/l/python-doxypypy/python-doxypypy.SlackBuild
new file mode 100755
index 000000000..a6f7bff9e
--- /dev/null
+++ b/source/l/python-doxypypy/python-doxypypy.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Copyright 2021 Patrick J. Volkerding, Sebeka, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=python-doxypypy
+SRCNAM=doxypypy
+VERSION=${VERSION:-$(echo ${SRCNAM}-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z || exit 1
+cd $SRCNAM-$VERSION || exit 1
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a *.rst LICENSE* NOTICE PKG-INFO \
+ $PKG/usr/doc/$PKGNAM-$VERSION
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
+
+# If there's a HISTORY.rst, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r HISTORY.rst ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat HISTORY.rst | head -n 1000 > $DOCSDIR/HISTORY.rst
+ touch -r HISTORY.rst $DOCSDIR/HISTORY.rst
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz