summaryrefslogtreecommitdiffstats
path: root/source/l/python-distro/python-distro.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-01-04 22:21:30 +0000
committer Eric Hameleers <alien@slackware.com>2020-01-05 08:59:50 +0100
commit4f5eb0f5505bf4c6361e2b2ebea465b559006a7e (patch)
tree4546c7c6e62cfa608f5ddcd8c19fdb39cc85ebfb /source/l/python-distro/python-distro.SlackBuild
parent1448fe3879c97183a67f452d2d54ffdbabd510dc (diff)
downloadcurrent-4f5eb0f5505bf4c6361e2b2ebea465b559006a7e.tar.gz
current-4f5eb0f5505bf4c6361e2b2ebea465b559006a7e.tar.xz
Sat Jan 4 22:21:30 UTC 202020200104222130
a/hwdata-0.331-noarch-1.txz: Upgraded. a/kernel-generic-5.4.8-x86_64-1.txz: Upgraded. a/kernel-huge-5.4.8-x86_64-1.txz: Upgraded. a/kernel-modules-5.4.8-x86_64-1.txz: Upgraded. ap/cups-filters-1.26.1-x86_64-1.txz: Upgraded. d/help2man-1.47.12-x86_64-1.txz: Upgraded. d/kernel-headers-5.4.8-x86-1.txz: Upgraded. k/kernel-source-5.4.8-noarch-1.txz: Upgraded. l/glib-networking-2.62.3-x86_64-1.txz: Upgraded. l/python-distro-1.4.0-x86_64-1.txz: Added. This is needed by hplip since Python 3.8 has removed the platform.linux_distribution function. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'source/l/python-distro/python-distro.SlackBuild')
-rwxr-xr-xsource/l/python-distro/python-distro.SlackBuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/source/l/python-distro/python-distro.SlackBuild b/source/l/python-distro/python-distro.SlackBuild
new file mode 100755
index 000000000..082560e05
--- /dev/null
+++ b/source/l/python-distro/python-distro.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/bash
+
+# Copyright 2017, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2018 Heinz Wiesinger, Amsterdam, NL
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=python-distro
+SRCNAM=distro
+VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z || exit 1
+cd $SRCNAM-$VERSION || exit 1
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python setup.py install --root=$PKG || exit 1
+python3 setup.py install --root=$PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a *.rst CHANGELOG* CONTRIBUTING* LICENSE* README* \
+ $PKG/usr/doc/$PKGNAM-$VERSION
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz