summaryrefslogtreecommitdiffstats
path: root/source/l/pycups/pycups.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2024-04-17 20:35:48 +0000
committer Eric Hameleers <alien@slackware.com>2024-04-17 23:41:21 +0200
commit2953aca3b1196570be74701d97c90c8c0b6b0d51 (patch)
treef84a47b25feade82fe455fe607531a3a7c0aec35 /source/l/pycups/pycups.SlackBuild
parent0172ca92cda072648ac2b648be4e3ed0c671b6ab (diff)
downloadcurrent-2953aca3b1196570be74701d97c90c8c0b6b0d51.tar.gz
current-2953aca3b1196570be74701d97c90c8c0b6b0d51.tar.xz
Wed Apr 17 20:35:48 UTC 202420240417203548
a/kernel-firmware-20240417_e678699-noarch-1.txz: Upgraded. a/kernel-generic-6.6.28-x86_64-1.txz: Upgraded. a/kernel-huge-6.6.28-x86_64-1.txz: Upgraded. a/kernel-modules-6.6.28-x86_64-1.txz: Upgraded. a/xfsprogs-6.7.0-x86_64-1.txz: Upgraded. d/kernel-headers-6.6.28-x86-1.txz: Upgraded. k/kernel-source-6.6.28-noarch-1.txz: Upgraded. l/pycups-2.0.3-x86_64-1.txz: Upgraded. l/python-sphinx-7.3.5-x86_64-1.txz: Upgraded. n/bluez-5.75-x86_64-2.txz: Rebuilt. Prune duplicate config files. Thanks to audriusk. x/libXmu-1.2.1-x86_64-1.txz: Upgraded. x/util-macros-1.20.1-noarch-1.txz: Upgraded. x/wayland-protocols-1.35-noarch-1.txz: Upgraded. xap/mozilla-thunderbird-115.10.0-x86_64-1.txz: Upgraded. This release contains security fixes and improvements. For more information, see: https://www.mozilla.org/en-US/thunderbird/115.10.0/releasenotes/ https://www.mozilla.org/en-US/security/known-vulnerabilities/thunderbird/#thunderbird115.10 (* Security fix *) xfce/xfce4-notifyd-0.9.4-x86_64-2.txz: Rebuilt. Do not install DBus service files, as these cause xfce4-notifyd to start in plasma sessions. Thanks to ctrlaltca. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'source/l/pycups/pycups.SlackBuild')
-rwxr-xr-xsource/l/pycups/pycups.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/source/l/pycups/pycups.SlackBuild b/source/l/pycups/pycups.SlackBuild
index 125b3902c..4b35c4e8d 100755
--- a/source/l/pycups/pycups.SlackBuild
+++ b/source/l/pycups/pycups.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2008 Heinz Wiesinger, Oggau, AT
-# Copyright 2008, 2009, 2010, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2018, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=pycups
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-7}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -65,8 +65,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
-make install-rpmhook DESTDIR=$PKG || exit 1
+# Requiring gcc and python3-devel in these files must be a mistake:
+cat $CWD/pycups.no.bogus.requires.diff | patch -p1 --verbose || exit 1
+
+make || exit 1
+make install DESTDIR=$PKG || exit 1
find $PKG | xargs file | grep -e "shared object" -e "executable" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -87,4 +90,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
-