summaryrefslogtreecommitdiffstats
path: root/source/l/pango/pango.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2016-06-30 20:26:57 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 23:31:18 +0200
commitd31c50870d0bee042ce660e445c9294a59a3a65b (patch)
tree6bfc0de3c95267b401b620c2c67859557dc60f97 /source/l/pango/pango.SlackBuild
parent76fc4757ac91ac7947a01fb7b53dddf9a78a01d1 (diff)
downloadcurrent-d31c50870d0bee042ce660e445c9294a59a3a65b.tar.gz
current-d31c50870d0bee042ce660e445c9294a59a3a65b.tar.xz
Slackware 14.2slackware-14.2
Thu Jun 30 20:26:57 UTC 2016 Slackware 14.2 x86_64 stable is released! The long development cycle (the Linux community has lately been living in "interesting times", as they say) is finally behind us, and we're proud to announce the release of Slackware 14.2. The new release brings many updates and modern tools, has switched from udev to eudev (no systemd), and adds well over a hundred new packages to the system. Thanks to the team, the upstream developers, the dedicated Slackware community, and everyone else who pitched in to help make this release a reality. The ISOs are off to be replicated, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. Please consider supporting the Slackware project by picking up a copy from store.slackware.com. We're taking pre-orders now, and offer a discount if you sign up for a subscription. Have fun! :-)
Diffstat (limited to 'source/l/pango/pango.SlackBuild')
-rwxr-xr-xsource/l/pango/pango.SlackBuild57
1 files changed, 7 insertions, 50 deletions
diff --git a/source/l/pango/pango.SlackBuild b/source/l/pango/pango.SlackBuild
index 9934c553d..34d4f7eb7 100755
--- a/source/l/pango/pango.SlackBuild
+++ b/source/l/pango/pango.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2015 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,15 +27,15 @@ BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
@@ -69,14 +69,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix for x86_64 (does not hurt the other archs but note that we will start
-# using /etc/pango/$host instead of /etc/pango/ now):
-zcat $CWD/pango.etc.host.location.diff.gz | patch -p1 --verbose || exit 1
-
-# Autoconf changes linux to linux-gnu.
-# Our host is $ARCH-slackware-linux not $ARCH-slackware-linux-gnu:
-sed -i -e 's#linux|linux-gnu|#linux|linux|#' config.sub
-
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -90,47 +82,12 @@ CFLAGS="$SLKCFLAGS" \
--target=$ARCH-slackware-linux
make $NUMJOBS || make || exit 1
-
-# Check the host value that is passed to the compile to the one in this script:
-host="$ARCH-slackware-linux"
-compile_host=$(grep 'host_triplet =' pango/Makefile | sed "s/.* = //")
-if [ "x$compile_host" != "x$host" ]; then
- echo "Host mismatch: compile='$compile_host', SlackBuild='$host'" && exit 1
-fi
-
make install DESTDIR=$PKG || exit 1
-# Install wrapper for pango-querymodules:
-cp $CWD/update-pango-querymodules $PKG/usr/bin/update-pango-querymodules
-chmod 0755 $PKG/usr/bin/update-pango-querymodules
-
# Do not remove pangox.aliases
-rm -f $PKG/etc/pango/pango.modules
-mkdir -p $PKG/etc/pango/$host
-touch $PKG/etc/pango/$host/pango.modules
-
-# We need to have separate 32-bit and 64-bit binaries
-# for places where we have two copies of the GTK+ package installed.
-# (we might have x86_64 and i486 packages on the same system, for example.)
-case "$host" in
- s390x*|x86_64*)
- mv $PKG/usr/bin/pango-querymodules $PKG/usr/bin/pango-querymodules-64
- ( cd $PKG/usr/bin ; ln -sf pango-querymodules-64 pango-querymodules )
- ;;
- *)
- mv $PKG/usr/bin/pango-querymodules $PKG/usr/bin/pango-querymodules-32
- ( cd $PKG/usr/bin ; ln -sf pango-querymodules-32 pango-querymodules )
- ;;
-esac
-
-mkdir -p $PKG/install
-cat <<EOF > $PKG/install/doinst.sh
-# Updating the pango.modules file:
-chroot . /sbin/ldconfig 2> /dev/null
-if [ -x /usr/bin/update-pango-querymodules ]; then
- /usr/bin/update-pango-querymodules
-fi
-EOF
+#rm -f $PKG/etc/pango/pango.modules
+#mkdir -p $PKG/etc/pango/$host
+#touch $PKG/etc/pango/$host/pango.modules
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null