summaryrefslogtreecommitdiffstats
path: root/source/l/netpbm/netpbm.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2010-05-19 08:58:23 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 22:43:05 +0200
commitb76270bf9e6dd375e495fec92140a79a79415d27 (patch)
tree3dbed78b2279bf9f14207a16dc634b90995cbd40 /source/l/netpbm/netpbm.SlackBuild
parent5a12e7c134274dba706667107d10d231517d3e05 (diff)
downloadcurrent-b76270bf9e6dd375e495fec92140a79a79415d27.tar.gz
current-b76270bf9e6dd375e495fec92140a79a79415d27.tar.xz
Slackware 13.1slackware-13.1
Wed May 19 08:58:23 UTC 2010 Slackware 13.1 x86_64 stable is released! Lots of thanks are due -- see the RELEASE_NOTES and the rest of the ChangeLog for credits. The ISOs are on their way to replication, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. We are taking pre-orders now at store.slackware.com, and offering a discount if you sign up for a subscription. Consider picking up a copy to help support the project. Thanks again to the Slackware community for testing, contributing, and generally holding us to a high level of quality. :-) Enjoy!
Diffstat (limited to 'source/l/netpbm/netpbm.SlackBuild')
-rwxr-xr-xsource/l/netpbm/netpbm.SlackBuild34
1 files changed, 25 insertions, 9 deletions
diff --git a/source/l/netpbm/netpbm.SlackBuild b/source/l/netpbm/netpbm.SlackBuild
index 0b6685c12..fedaffddb 100755
--- a/source/l/netpbm/netpbm.SlackBuild
+++ b/source/l/netpbm/netpbm.SlackBuild
@@ -22,10 +22,18 @@
PKGNAM=netpbm
-VERSION=${VERSION:-10.35.22}
-ARCH=${ARCH:-x86_64}
-BUILD=${BUILD:-2}
-
+VERSION=${VERSION:-10.49.02}
+BUILD=${BUILD:-1}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -36,6 +44,9 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
CWD=$(pwd)
@@ -46,7 +57,7 @@ mkdir -p $TMP # Do not create $PKG or 'make package' fails
cd $TMP
rm -rf ${PKGNAM}-${VERSION}
-tar xvf $CWD/${PKGNAM}-$VERSION.tar.bz2 || exit 1
+tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
cd ${PKGNAM}-$VERSION
# Make sure ownerships and permissions are sane:
@@ -59,10 +70,10 @@ find . \
# Configure:
if [ "$ARCH" = "x86_64" ]; then
- zcat $CWD/Makefile.config.gz \
- | sed -e '/^CFLAGS/s/^CFLAGS = .*/& -fPIC/' > Makefile.config
+ zcat $CWD/config.mk.gz \
+ | sed -e '/^CFLAGS/s/^CFLAGS = .*/& -fPIC/' > config.mk
else
- zcat $CWD/Makefile.config.gz > Makefile.config
+ zcat $CWD/config.mk.gz > config.mk
fi
# Build and install (does not like parallel build):
@@ -109,9 +120,14 @@ fi
# Add a documentation directory:
( cd doc
cp -a \
- COPYRIGHT.PATENT GPL_LICENSE.txt HISTORY INSTALL Netpbm.programming \
+ COPYRIGHT.PATENT GPL_LICENSE.txt INSTALL Netpbm.programming \
README* USERDOC copyright_summary lgpl_v21.txt \
$PKG/usr/doc/${PKGNAM}-$VERSION
+ if [ -r HISTORY ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat HISTORY | head -n 1000 > $DOCSDIR/HISTORY
+ touch -r HISTORY $DOCSDIR/HISTORY
+ fi
)
mkdir -p $PKG/install