summaryrefslogtreecommitdiffstats
path: root/source/l/libtermcap/libtermcap.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2018-05-28 19:12:29 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 23:39:35 +0200
commit646a5c1cbfd95873950a87b5f75d52073a967023 (patch)
treeb8b8d2ab3b0d432ea69ad1a64d1c789649d65020 /source/l/libtermcap/libtermcap.SlackBuild
parentd31c50870d0bee042ce660e445c9294a59a3a65b (diff)
downloadcurrent-646a5c1cbfd95873950a87b5f75d52073a967023.tar.gz
current-646a5c1cbfd95873950a87b5f75d52073a967023.tar.xz
Mon May 28 19:12:29 UTC 201820180528191229
a/pkgtools-15.0-noarch-13.txz: Rebuilt. installpkg: default line length for --terselength is the number of columns. removepkg: added --terse mode. upgradepkg: default line length for --terselength is the number of columns. upgradepkg: accept -option in addition to --option. ap/vim-8.1.0026-x86_64-1.txz: Upgraded. d/bison-3.0.5-x86_64-1.txz: Upgraded. e/emacs-26.1-x86_64-1.txz: Upgraded. kde/kopete-4.14.3-x86_64-8.txz: Rebuilt. Recompiled against libidn-1.35. n/conntrack-tools-1.4.5-x86_64-1.txz: Upgraded. n/libnetfilter_conntrack-1.0.7-x86_64-1.txz: Upgraded. n/libnftnl-1.1.0-x86_64-1.txz: Upgraded. n/links-2.16-x86_64-2.txz: Rebuilt. Rebuilt to enable X driver for -g mode. n/lynx-2.8.9dev.19-x86_64-1.txz: Upgraded. n/nftables-0.8.5-x86_64-1.txz: Upgraded. n/p11-kit-0.23.11-x86_64-1.txz: Upgraded. n/ulogd-2.0.7-x86_64-1.txz: Upgraded. n/whois-5.3.1-x86_64-1.txz: Upgraded. xap/network-manager-applet-1.8.12-x86_64-1.txz: Upgraded. xap/vim-gvim-8.1.0026-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/libtermcap/libtermcap.SlackBuild')
-rwxr-xr-xsource/l/libtermcap/libtermcap.SlackBuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/source/l/libtermcap/libtermcap.SlackBuild b/source/l/libtermcap/libtermcap.SlackBuild
deleted file mode 100755
index 12e027637..000000000
--- a/source/l/libtermcap/libtermcap.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Copyright 2005-2010 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-VERSION=1.2.3
-BUILD=${BUILD:-7}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-libtermcap
-
-if [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-
-cd $TMP
-tar xzvf $CWD/termcap-compat_$VERSION.tar.gz
-cd termcap-compat-$VERSION
-chown -R root.root .
-zcat $CWD/termcap-compat_$VERSION.diff.gz | patch -p1 --verbose --backup --suffix=.orig
-zcat $CWD/termcap.h.diff.gz | patch -p0 --verbose --backup --suffix=.orig
-zcat $CWD/termcap.bufsize.diff.gz | patch -p1 --verbose --backup --suffix=.orig
-
-make
-
-# Install stuff manually:
-mkdir -p $PKG/lib${LIBDIRSUFFIX} $PKG/usr/lib${LIBDIRSUFFIX} \
- $PKG/usr/{include,info}
-install -m755 libtermcap.so.* $PKG/lib${LIBDIRSUFFIX}/
-install -m644 libtermcap.a $PKG/usr/lib${LIBDIRSUFFIX}/
-install -m644 termcap.h $PKG/usr/include/
-install -m644 termcap.info* $PKG/usr/info/
-
-( cd $PKG/lib${LIBDIRSUFFIX} ; ldconfig -n . ; chown root:root libtermcap* )
-( cd $PKG/usr/lib${LIBDIRSUFFIX}
- rm -f libermcap.so*
- ln -sf /lib${LIBDIRSUFFIX}/$(basename $(find $PKG/lib${LIBDIRSUFFIX} -type f)) libtermcap.so
-)
-
-# Save docs:
-mkdir -p $PKG/usr/doc/termcap-$VERSION
-cp -a ChangeLog debian/changelog README $PKG/usr/doc/termcap-$VERSION
-
-# Compress the info pages:
-( cd $PKG/usr/info ; gzip -9f *.info* )
-
-# Add the package description:
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-makepkg -l y -c n $TMP/libtermcap-$VERSION-$ARCH-$BUILD.txz
-