summaryrefslogtreecommitdiffstats
path: root/source/l/libappindicator/libappindicator.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2024-03-17 21:11:08 +0000
committer Eric Hameleers <alien@slackware.com>2024-03-17 23:12:19 +0100
commitff3cad8da36c501fccb6a4931bc29dbf81601932 (patch)
tree778bae41314342cb40fce6553ac02269c1c51a71 /source/l/libappindicator/libappindicator.SlackBuild
parent075d1459e589bd7cd67d3b6c7fe86edc856bc017 (diff)
downloadcurrent-ff3cad8da36c501fccb6a4931bc29dbf81601932.tar.gz
current-ff3cad8da36c501fccb6a4931bc29dbf81601932.tar.xz
Sun Mar 17 21:11:08 UTC 202420240317211108
La fheile Padraig sona dhaoibh! Pionta Guinness, le do thoil. :-) kde/digikam-8.3.0-x86_64-2.txz: Rebuilt. Fixed internal version number. l/harfbuzz-8.3.1-x86_64-1.txz: Upgraded. l/libappindicator-12.10.0-x86_64-4.txz: Rebuilt. Drop the python bindings. l/mozilla-nss-3.99-x86_64-1.txz: Upgraded. l/python-hatchling-1.22.2-x86_64-1.txz: Upgraded. l/python-markdown-3.6-x86_64-1.txz: Upgraded. l/python-zipp-3.18.1-x86_64-1.txz: Upgraded. l/qt5-5.15.13_20240314_6694e805-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/libappindicator/libappindicator.SlackBuild')
-rwxr-xr-xsource/l/libappindicator/libappindicator.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/source/l/libappindicator/libappindicator.SlackBuild b/source/l/libappindicator/libappindicator.SlackBuild
index 695ea5e8f..649589179 100755
--- a/source/l/libappindicator/libappindicator.SlackBuild
+++ b/source/l/libappindicator/libappindicator.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2015 Eric Hameleers, Eindhoven, NL
-# Copyright 2020 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2020, 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libappindicator
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-4}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -86,7 +86,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-for file in bindings/python/Makefile.in bindings/python/Makefile.am example/Makefile.in example/Makefile.am src/Makefile.in src/Makefile.am tests/Makefile.in tests/Makefile.am ; do
+cat $CWD/libappindicator-no-python.patch | patch -p1 --verbose || exit 1
+autoreconf -vif
+
+for file in example/Makefile.in example/Makefile.am src/Makefile.in src/Makefile.am tests/Makefile.in tests/Makefile.am ; do
sed -i "s/-Werror//g" $file
done