summaryrefslogtreecommitdiffstats
path: root/source/l/gtk+3/gtk+3.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-04-27 20:27:30 +0000
committer Eric Hameleers <alien@slackware.com>2020-04-28 08:59:53 +0200
commit1cf9f87b65a9ec2c65a1fb409fe9e42a53af778f (patch)
tree9ae4603721b75831fd6e3cb8c5b7f9d192691d72 /source/l/gtk+3/gtk+3.SlackBuild
parent6e0d30774ba3f189660e7672e0ad5fa88a259b6b (diff)
downloadcurrent-1cf9f87b65a9ec2c65a1fb409fe9e42a53af778f.tar.gz
current-1cf9f87b65a9ec2c65a1fb409fe9e42a53af778f.tar.xz
Mon Apr 27 20:27:30 UTC 202020200427202730
a/mkinitrd-1.4.11-x86_64-15.txz: Rebuilt. Use the standard mktemp utility from GNU coreutils, not the old tempfile. d/help2man-1.47.15-x86_64-1.txz: Upgraded. l/aspell-en-2019.10.06_0-x86_64-1.txz: Upgraded. l/gtk+3-3.24.20-x86_64-1.txz: Upgraded. l/imagemagick-7.0.10_9-x86_64-1.txz: Upgraded. n/irssi-1.2.2-x86_64-2.txz: Rebuilt. Fixed ctrl-space killing input with recent glib. Thanks to tramtrist and Urchlay. x/xterm-354-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-de-20161207_7_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-ga-5.1_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-it-2.4_20070901_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-ml-0.04_1-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-pl-6.0_20200327_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-pt_BR-20131030_12_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-pt_PT-20190329_1_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-sk-2.02_0-x86_64-1.txz: Upgraded. extra/aspell-word-lists/aspell-tl-0.4_0-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/gtk+3/gtk+3.SlackBuild')
-rwxr-xr-xsource/l/gtk+3/gtk+3.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/source/l/gtk+3/gtk+3.SlackBuild b/source/l/gtk+3/gtk+3.SlackBuild
index cd05ae4ce..377b619a9 100755
--- a/source/l/gtk+3/gtk+3.SlackBuild
+++ b/source/l/gtk+3/gtk+3.SlackBuild
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gtk+3
VERSION=${VERSION:-$(echo gtk+-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -77,8 +77,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Fix embedded version number:
-zcat $CWD/gtk.meson.build.version.diff.gz | patch -p1 --verbose || exit 1
+# The version-check.py seems to be missing from the top-level directory, but
+# since we've checked the version numbers manually we'll just fix things so
+# the configure process doesn't try to call it:
+zcat $CWD/gtk.fix.missing.version-check.py.diff.gz | patch -p1 --verbose || exit 1
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"