summaryrefslogtreecommitdiffstats
path: root/source/l/gtk+3/gtk+3.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-04-15 19:52:52 +0000
committer Eric Hameleers <alien@slackware.com>2020-04-16 08:59:52 +0200
commit56d77dd7f41b963d5026c618cd7668e277de5b12 (patch)
tree3cead9562062c5bcce4fa10d4b185973fa2398c1 /source/l/gtk+3/gtk+3.SlackBuild
parent4bb8e72194ac7157012e8fab88662688c811c295 (diff)
downloadcurrent-ba23b5bc0ef7bdaf14df308d102303d9aa5450e3.tar.gz
current-ba23b5bc0ef7bdaf14df308d102303d9aa5450e3.tar.xz
Wed Apr 15 19:52:52 UTC 202020200415195252
a/xfsprogs-5.6.0-x86_64-1.txz: Upgraded. l/gtk+3-3.24.18-x86_64-2.txz: Rebuilt. Fixed the version number embedded in pkg-config files and elsewhere. Thanks to davjohn for the bug report. n/bind-9.16.2-x86_64-1.txz: Upgraded. This update fixes a security issue: DNS rebinding protection was ineffective when BIND 9 is configured as a forwarding DNS server. Found and responsibly reported by Tobias Klein. [GL #1574] (* Security fix *)
Diffstat (limited to 'source/l/gtk+3/gtk+3.SlackBuild')
-rwxr-xr-xsource/l/gtk+3/gtk+3.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/source/l/gtk+3/gtk+3.SlackBuild b/source/l/gtk+3/gtk+3.SlackBuild
index fd7300307..cd05ae4ce 100755
--- a/source/l/gtk+3/gtk+3.SlackBuild
+++ b/source/l/gtk+3/gtk+3.SlackBuild
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gtk+3
VERSION=${VERSION:-$(echo gtk+-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -77,6 +77,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
+# Fix embedded version number:
+zcat $CWD/gtk.meson.build.version.diff.gz | patch -p1 --verbose || exit 1
+
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
export CXXFLAGS="$SLKCFLAGS -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"