summaryrefslogtreecommitdiffstats
path: root/source/l/giflib/giflib.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2010-05-19 08:58:23 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 22:43:05 +0200
commitb76270bf9e6dd375e495fec92140a79a79415d27 (patch)
tree3dbed78b2279bf9f14207a16dc634b90995cbd40 /source/l/giflib/giflib.SlackBuild
parent5a12e7c134274dba706667107d10d231517d3e05 (diff)
downloadcurrent-b76270bf9e6dd375e495fec92140a79a79415d27.tar.gz
current-b76270bf9e6dd375e495fec92140a79a79415d27.tar.xz
Slackware 13.1slackware-13.1
Wed May 19 08:58:23 UTC 2010 Slackware 13.1 x86_64 stable is released! Lots of thanks are due -- see the RELEASE_NOTES and the rest of the ChangeLog for credits. The ISOs are on their way to replication, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. We are taking pre-orders now at store.slackware.com, and offering a discount if you sign up for a subscription. Consider picking up a copy to help support the project. Thanks again to the Slackware community for testing, contributing, and generally holding us to a high level of quality. :-) Enjoy!
Diffstat (limited to '')
-rwxr-xr-xsource/l/giflib/giflib.SlackBuild (renamed from source/l/libungif/libungif.SlackBuild)72
1 files changed, 44 insertions, 28 deletions
diff --git a/source/l/libungif/libungif.SlackBuild b/source/l/giflib/giflib.SlackBuild
index 5e9ff8c06..e2390a253 100755
--- a/source/l/libungif/libungif.SlackBuild
+++ b/source/l/giflib/giflib.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -20,11 +20,20 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+VERSION=${VERSION:-$(echo giflib-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
-VERSION=4.1.4
-ARCH=${ARCH:-x86_64}
NUMJOBS=${NUMJOBS:-" -j7 "}
-BUILD=${BUILD:-4}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -35,18 +44,21 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
CWD=$(pwd)
TMP=${TMP:-/tmp}
-PKG=$TMP/package-libungif
+PKG=$TMP/package-giflib
+
rm -rf $PKG
mkdir -p $TMP $PKG
-
cd $TMP
-rm -rf libungif-$VERSION
-tar xvf $CWD/libungif-$VERSION.tar.bz2 || exit 1
-cd libungif-$VERSION
+rm -rf giflib-$VERSION
+tar xvf $CWD/giflib-$VERSION.tar.?z* || exit 1
+cd giflib-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -58,36 +70,40 @@ CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
--with-x=no \
- $ARCH-slackware-linux
+ --disable-static \
+ --build=$ARCH-slackware-linux
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
-mkdir -p $PKG/usr/doc/libungif-$VERSION
+# Make some compatibility symlinks
+( cd $PKG/usr/lib${LIBDIRSUFFIX}
+ ln -s libgif.so.4 libungif.so.4
+ ln -s libgif.so libungif.so
+)
+
+mkdir -p $PKG/usr/doc/giflib-$VERSION
cp -a \
- AUTHORS BUGS COPYING ChangeLog INSTALL NEWS ONEWS README TODO \
- UNCOMPRESSED_GIF doc \
- $PKG/usr/doc/libungif-$VERSION
-rm $PKG/usr/doc/libungif-$VERSION/doc/Makefile*
+ AUTHORS BUGS COPYING DEVELOPERS INSTALL NEWS ONEWS README TODO \
+ $PKG/usr/doc/giflib-$VERSION
+cp -a doc $PKG/usr/doc/giflib-$VERSION/html
+rm $PKG/usr/doc/giflib-$VERSION/html/Makefile*
+
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-## I don't believe we need all this slop. Correct me if I'm wrong.
-# I've been corrected...
-#rm -rf $PKG/usr/bin
-
-( cd $PKG/usr/lib${LIBDIRSUFFIX}
- SOVER=$(/bin/ls libungif.so.*.*.* | cut -f 3-5 -d .)
- ln -sf libungif.so.$SOVER libgif.so.$SOVER
- ln -sf libgif.so.$SOVER libgif.so.4
- ln -sf libgif.so.4 libgif.so
- ln -sf libungif.a libgif.a )
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $TMP/libungif-$VERSION-$ARCH-$BUILD.txz
-
+/sbin/makepkg -l y -c n $TMP/giflib-$VERSION-$ARCH-$BUILD.txz