summaryrefslogtreecommitdiffstats
path: root/source/l/gc/gc.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2016-06-30 20:26:57 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 23:31:18 +0200
commitd31c50870d0bee042ce660e445c9294a59a3a65b (patch)
tree6bfc0de3c95267b401b620c2c67859557dc60f97 /source/l/gc/gc.SlackBuild
parent76fc4757ac91ac7947a01fb7b53dddf9a78a01d1 (diff)
downloadcurrent-d31c50870d0bee042ce660e445c9294a59a3a65b.tar.gz
current-d31c50870d0bee042ce660e445c9294a59a3a65b.tar.xz
Slackware 14.2slackware-14.2
Thu Jun 30 20:26:57 UTC 2016 Slackware 14.2 x86_64 stable is released! The long development cycle (the Linux community has lately been living in "interesting times", as they say) is finally behind us, and we're proud to announce the release of Slackware 14.2. The new release brings many updates and modern tools, has switched from udev to eudev (no systemd), and adds well over a hundred new packages to the system. Thanks to the team, the upstream developers, the dedicated Slackware community, and everyone else who pitched in to help make this release a reality. The ISOs are off to be replicated, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. Please consider supporting the Slackware project by picking up a copy from store.slackware.com. We're taking pre-orders now, and offer a discount if you sign up for a subscription. Have fun! :-)
Diffstat (limited to 'source/l/gc/gc.SlackBuild')
-rwxr-xr-xsource/l/gc/gc.SlackBuild69
1 files changed, 50 insertions, 19 deletions
diff --git a/source/l/gc/gc.SlackBuild b/source/l/gc/gc.SlackBuild
index 70c9595af..186f39872 100755
--- a/source/l/gc/gc.SlackBuild
+++ b/source/l/gc/gc.SlackBuild
@@ -1,6 +1,7 @@
#!/bin/sh
-# Copyright 2013 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2013, 2014, 2015 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2014 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,12 +24,12 @@
PKGNAM=gc
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-3}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
@@ -43,8 +44,8 @@ PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $PKG/usr
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
@@ -61,6 +62,8 @@ cd $TMP
rm -rf $PKGNAM-$VERSION $PKGNAM-$(echo $VERSION | cut -b 1-3)
tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
cd $PKGNAM-$VERSION 2> /dev/null || cd $PKGNAM-$(echo $VERSION | cut -b 1-3) || exit 1
+tar xvf $CWD/libatomic_ops-$VERSION.tar.xz || exit 1
+mv libatomic_ops-$VERSION libatomic_ops
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -68,17 +71,29 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-zcat $CWD/gc.test-stack-infinite-loop.diff.gz | patch -p1 --verbose || exit 1
+# https://github.com/ivmai/bdwgc/pull/51
+zcat $CWD/noelision.patch.gz | patch -p1 --verbose || exit 1
-CFLAGS="$SLKCFLAGS" \
+# Guarding GC_setup_mark_lock usage with PARALLEL_MARK is required to avoid
+# an undefined reference in non-PARALLEL_MARK configurations:
+zcat $CWD/refer_to_GC_setup_mark_lock_only_in_PARALLEL_MARK_code.patch.gz | patch -p0 --verbose || exit 1
+
+sed -i 's#pkgdata#doc#' doc/doc.am
+sed -i 's#pkgdata#doc#' libatomic_ops/Makefile.am
+sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
+
+autoreconf -vif
+automake --add-missing
+
+# See bugzilla.redhat.com/689877 for -DUSE_GET_STACKBASE_FOR_MAIN
+
+CFLAGS="$SLKCFLAGS -DUSE_GET_STACKBASE_FOR_MAIN" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--infodir=/usr/info \
--mandir=/usr/man \
- --disable-static \
--disable-dependency-tracking \
- --disable-static \
--enable-cplusplus \
--enable-large-config \
--enable-parallel-mark \
@@ -86,10 +101,32 @@ CFLAGS="$SLKCFLAGS" \
--with-libatomic-ops=no \
--build=$ARCH-slackware-linux
+# NOTE: Using --disable-static exports a subset of symbols, and has caused
+# some things that use gc to break. So it is recommended to build the static
+# libraries and then remove them before packaging.
+
# Does not like parallel make...
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
+mkdir -p $PKG/usr/man/man3
+sed -i -e 's/GC_MALLOC 1L/gc 3/' doc/gc.man
+install -m 644 doc/gc.man $PKG/usr/man/man3/gc.3
+
+# Install libatomic_ops
+cd libatomic_ops
+ make install DESTDIR=$PKG || exit 1
+cd -
+
+# Remove static libraries that we don't want in the package, and fix the
+# .la files to remove the references to them:
+( cd $PKG/usr/lib${LIBDIRSUFFIX}
+ for static in libcord libgc libgccpp ; do
+ rm --verbose ${static}.a
+ sed -i "s#old_library='.*'#old_library=''#g" ${static}.la
+ done
+)
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -108,18 +145,12 @@ if [ -d $PKG/usr/man ]; then
)
fi
-# Compress info files, if any:
-if [ -d $PKG/usr/info ]; then
- ( cd $PKG/usr/info
- rm -f dir
- gzip -9 *
- )
-fi
-
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+mv $PKG/usr/share/doc/* $PKG/usr/doc/$PKGNAM-$VERSION/
+rm -f $PKG/usr/doc/$PKGNAM-$VERSION/gc/gc.man
+rm -rf $PKG/usr/share
cp -a \
- AUTHORS COPYING* FAQ GUILE-VERSION \
- HACKING INSTALL LICENSE NEWS README* THANKS \
+ README.QUICK TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install