summaryrefslogtreecommitdiffstats
path: root/source/l/M2Crypto/M2Crypto.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-04-21 02:45:06 +0000
committer Eric Hameleers <alien@slackware.com>2020-04-21 08:59:53 +0200
commit72b3c9e90fc0aaa9889f6be69da37f506cabeba2 (patch)
treea352ce07c0e6d2ee838fb9d34ad0d2010bc402d8 /source/l/M2Crypto/M2Crypto.SlackBuild
parenta4a9ee5efe6ec1f8cc7c5fd48c5df766fc74f3f3 (diff)
downloadcurrent-4f920392afbf46148fd98dbd02fa91567c62c442.tar.gz
current-4f920392afbf46148fd98dbd02fa91567c62c442.tar.xz
Tue Apr 21 02:45:06 UTC 202020200421024506
d/python-2.7.17-x86_64-2.txz: Removed. d/python2-2.7.18-x86_64-1.txz: Added. OK, I know a few people got excited seeing python-2 removed in the previous entry, but it's just being renamed to python2 for consistency with the python3 package. It's DOA though, and is the final release of the already EOL python 2 branch (a "commemorative" release as they say in the announcement). l/M2Crypto-0.35.2-x86_64-3.txz: Rebuilt. Added python3 modules. Thanks to sombragris and ponce. l/harfbuzz-2.6.5-x86_64-1.txz: Upgraded. l/imagemagick-7.0.10_7-x86_64-1.txz: Upgraded. l/libuv-1.37.0-x86_64-1.txz: Upgraded. l/libyaml-0.2.4-x86_64-1.txz: Upgraded. l/oniguruma-6.9.5-x86_64-1.txz: Upgraded. x/pixman-0.40.0-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/M2Crypto/M2Crypto.SlackBuild')
-rwxr-xr-xsource/l/M2Crypto/M2Crypto.SlackBuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/source/l/M2Crypto/M2Crypto.SlackBuild b/source/l/M2Crypto/M2Crypto.SlackBuild
index 28a7a45e6..0491c1b76 100755
--- a/source/l/M2Crypto/M2Crypto.SlackBuild
+++ b/source/l/M2Crypto/M2Crypto.SlackBuild
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=M2Crypto
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -62,6 +62,7 @@ find . \
-exec chmod 644 {} \+
python setup.py install --root=$PKG || exit 1
+python3 setup.py install --root=$PKG || exit 1
mkdir -p $PKG/usr/doc/M2Crypto-$VERSION
cp -a \
@@ -70,9 +71,9 @@ cp -a \
# Embed required dep typing module:
cd $TMP
-rm -rf typing-3.7.4
-tar xvf $CWD/typing-3.7.4.tar.xz || exit 1
-cd typing-3.7.4 || exit 1
+rm -rf typing-3.7.4.1
+tar xvf $CWD/typing-3.7.4.1.tar.xz || exit 1
+cd typing-3.7.4.1 || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -80,10 +81,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
python setup.py install --root=$PKG || exit 1
-mkdir -p $PKG/usr/doc/typing-3.7.4
+python3 setup.py install --root=$PKG || exit 1
+mkdir -p $PKG/usr/doc/typing-3.7.4.1
cp -a \
CHANGES INSTALL* LICENCE* PKG-INFO README* doc/* \
- $PKG/usr/doc/typing-3.7.4
+ $PKG/usr/doc/typing-3.7.4.1
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \