summaryrefslogtreecommitdiffstats
path: root/source/d/binutils/binutils.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2021-01-30 21:55:04 +0000
committer Eric Hameleers <alien@slackware.com>2021-01-31 08:59:50 +0100
commit2c78f43e266f5e7d7b0903f1199441ed19451a08 (patch)
tree66eaacffb3ce96e6ec8700bafb37744e1499bfe7 /source/d/binutils/binutils.SlackBuild
parent8040f7f06757d6830029f75eab44474464883f59 (diff)
downloadcurrent-2c78f43e266f5e7d7b0903f1199441ed19451a08.tar.gz
current-2c78f43e266f5e7d7b0903f1199441ed19451a08.tar.xz
Sat Jan 30 21:55:04 UTC 202120210130215504
a/e2fsprogs-1.46.0-x86_64-1.txz: Upgraded. a/kernel-generic-5.10.12-x86_64-1.txz: Upgraded. a/kernel-huge-5.10.12-x86_64-1.txz: Upgraded. a/kernel-modules-5.10.12-x86_64-1.txz: Upgraded. a/sysklogd-2.2.1-x86_64-1.txz: Upgraded. d/binutils-2.35.2-x86_64-1.txz: Upgraded. We're probably better off with this branch for now. d/kernel-headers-5.10.12-x86-1.txz: Upgraded. d/oprofile-1.4.0-x86_64-5.txz: Rebuilt. Recompiled against binutils-2.35.2. k/kernel-source-5.10.12-noarch-1.txz: Upgraded. l/gd-2.3.1-x86_64-1.txz: Upgraded. l/libwebp-1.2.0-x86_64-1.txz: Upgraded. l/python-packaging-20.9-x86_64-1.txz: Upgraded. x/fcitx-libpinyin-0.5.4-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'source/d/binutils/binutils.SlackBuild')
-rwxr-xr-xsource/d/binutils/binutils.SlackBuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/source/d/binutils/binutils.SlackBuild b/source/d/binutils/binutils.SlackBuild
index 8ef3e83e0..a8d06985b 100755
--- a/source/d/binutils/binutils.SlackBuild
+++ b/source/d/binutils/binutils.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2005-2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2005-2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=binutils
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
MARCH=$( uname -m )
@@ -106,9 +106,6 @@ zcat $CWD/patches/binutils.export.demangle.h.diff.gz | patch -p1 --verbose || ex
# Don't check to see if "config.h" was included in the installed headers:
zcat $CWD/patches/binutils.no-config-h-check.diff.gz | patch -p1 --verbose || exit 1
-# Revert patch that breaks the kernel build. No || exit 1 because of ChangeLog patch rejections:
-zcat $CWD/patches/0001-ELF-Don-t-generate-unused-section-symbols.patch.gz | patch -p1 -R
-
# Set %version to something halfway meaningful:
sed -i -e 's/%''{release}/slack15/g' bfd/Makefile{.am,.in}
@@ -205,12 +202,12 @@ fi
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-# Remove some unneeded man pages, and then compress the rest
-rm -f $PKG/usr/man/man1/{dlltool,windres}.1
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \+
- for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+# Compress manual pages:
+find $PKG/usr/man -type f -exec gzip -9 {} \+
+for i in $( find $PKG/usr/man -type l ) ; do
+ ln -s $( readlink $i ).gz $i.gz
+ rm $i
+done
# Compress info pages
rm -f $PKG/usr/info/dir