summaryrefslogtreecommitdiffstats
path: root/source/ap/screen/screen.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2019-10-02 19:41:47 +0000
committer Eric Hameleers <alien@slackware.com>2019-10-03 08:59:49 +0200
commit27dce94811b1253ee685b40a4a5a70bce92b5cbd (patch)
treebf2b95dabb3da6b90f593f1a847b01d1bb00c4a0 /source/ap/screen/screen.SlackBuild
parent9f3af3accb48f4e6c3ae536251b11d7f70bdb74c (diff)
downloadcurrent-27dce94811b1253ee685b40a4a5a70bce92b5cbd.tar.gz
current-27dce94811b1253ee685b40a4a5a70bce92b5cbd.tar.xz
Wed Oct 2 19:41:47 UTC 201920191002194147
a/haveged-1.9.8-x86_64-1.txz: Upgraded. ap/screen-4.7.0-x86_64-1.txz: Upgraded. ap/vim-8.1.2108-x86_64-1.txz: Upgraded. d/rust-1.37.0-x86_64-1.txz: Upgraded. Reverting to rust-1.37.0 after verified reports that the newer Rust is unable to compile Firefox or Thunderbird. There are some patches for this appearing in the repos, but they are extensive changes that don't look like they could be cherry-picked. Hey, at least this Rust version works and is not bloated. :) Moving forward we'll be testing new versions of Rust to make sure that they can compile the sources that we need Rust for before merging them into the tree. Firefox has been verified to build here with rust-1.37.0 and gcc/g++ from gcc-9.2.0 or clang/clang++ from llvm-9.0.0. l/libcap-ng-0.7.10-x86_64-1.txz: Upgraded. xap/vim-gvim-8.1.2108-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/ap/screen/screen.SlackBuild')
-rwxr-xr-xsource/ap/screen/screen.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/source/ap/screen/screen.SlackBuild b/source/ap/screen/screen.SlackBuild
index 277ae041d..dc7f2ded7 100755
--- a/source/ap/screen/screen.SlackBuild
+++ b/source/ap/screen/screen.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2015, 2016, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2015, 2016, 2018, 2019 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=screen
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -63,7 +63,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf screen-$VERSION
-tar xvf $CWD/screen-$VERSION.tar.?z* || exit 1
+tar xvf $CWD/screen-$VERSION.tar.?z || exit 1
cd screen-$VERSION || exit 1
@@ -86,12 +86,6 @@ done
# the console from being properly cleared when detaching from a screen session:
zcat $CWD/60-revert-screenrc-change.diff.gz | patch -p1 --verbose || exit 1
-# Do not link against libelf:
-zcat $CWD/screen.no_libelf.diff.gz | patch -p1 --verbose || exit 1
-
-# Reconf after patching configure.ac:
-autoreconf -vif
-
# Configure:
CFLAGS="$SLKCFLAGS" \
./configure \