summaryrefslogtreecommitdiffstats
path: root/source/ap/man-pages/man-pages.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2020-02-11 04:45:36 +0000
committer Eric Hameleers <alien@slackware.com>2020-02-11 08:59:47 +0100
commite1ab44f93f91f5c967ac1b7143c7a8ac287d1a52 (patch)
tree34c8b4e186959832c23d97726c0646e23b701085 /source/ap/man-pages/man-pages.SlackBuild
parent0582d0c1740d0bce4f06ec9f682d87a766b50b57 (diff)
downloadcurrent-e1ab44f93f91f5c967ac1b7143c7a8ac287d1a52.tar.gz
current-e1ab44f93f91f5c967ac1b7143c7a8ac287d1a52.tar.xz
Tue Feb 11 04:45:36 UTC 202020200211044536
ap/man-pages-5.05-noarch-2.txz: Rebuilt. Clean up /usr/man directory moving miscellaneous documentation to /usr/doc/man-pages-5.05. Thanks to Xsane. d/python-setuptools-45.2.0-x86_64-1.txz: Upgraded. n/nfs-utils-2.4.3-x86_64-1.txz: Upgraded. xap/mozilla-firefox-68.5.0esr-x86_64-1.txz: Upgraded. This is a bugfix release. For more information, see: https://www.mozilla.org/en-US/firefox/68.5.0/releasenotes/
Diffstat (limited to 'source/ap/man-pages/man-pages.SlackBuild')
-rwxr-xr-xsource/ap/man-pages/man-pages.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/source/ap/man-pages/man-pages.SlackBuild b/source/ap/man-pages/man-pages.SlackBuild
index 09bf90cbd..db9bae934 100755
--- a/source/ap/man-pages/man-pages.SlackBuild
+++ b/source/ap/man-pages/man-pages.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008-2019 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008-2020 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=man-pages
VERSION=${VERSION:-$(echo man-pages-5.*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
ARCH=noarch
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
@@ -60,23 +60,17 @@ find man-pages-posix-2013-a \
-exec chmod 644 {} \+
mkdir -p $PKG/usr/man
-cp -a man-pages-$VERSION/* $PKG/usr/man
+cp -a man-pages-$VERSION/man? $PKG/usr/man
-# The pthread manpages are the only POSIX ones that anyone
-# has requested saving. If I missed anything important, let me know.
-mv man-pages-posix-2013-a/man0p/pthread.h.0p $PKG/usr/man/man3/pthread.h.3p
-mv man-pages-posix-2013-a/man3p/pthread_* $PKG/usr/man/man3
-cp man-pages-posix-2013-a/POSIX-COPYRIGHT $PKG/usr/man
# Are these other POSIX manpages of any real usefulness here?
# Granted there may be some historical interest, and it's nice
# to have them in the source package for that reason, but it
# seems to me that installing them on the system by default
# isn't likely to help most people and may lead to confusion.
-
-# Also probably not needed in the package
-rm -rf $PKG/usr/man/scripts
-rm -f $PKG/usr/man/Makefile
-rm -f $PKG/usr/man/Changes.old
+# The pthread manpages are the only POSIX ones that anyone
+# has requested saving. If I missed anything important, let me know.
+cp -a man-pages-posix-2013-a/man0p/pthread.h.0p $PKG/usr/man/man3/pthread.h.3p
+cp -a man-pages-posix-2013-a/man3p/pthread_* $PKG/usr/man/man3
# Compress the pages:
echo "Compressing manpages..."
@@ -101,6 +95,13 @@ rm -r $TEMPDIR
# Some of the posix pages don't display correctly without this
( cd $PKG/usr/man ; ln -s man3 man3p )
+# Add a documentation directory:
+mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
+cp -a \
+ man-pages-$VERSION/{CONTRIBUTING,Changes,README,man-pages-5.05.Announce,man-pages-5.05.lsm} \
+ man-pages-posix-2013-a/POSIX-COPYRIGHT \
+ $PKG/usr/doc/${PKGNAM}-$VERSION
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc