summaryrefslogtreecommitdiffstats
path: root/source/ap/man-pages/man-pages.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2019-03-07 21:26:58 +0000
committer Eric Hameleers <alien@slackware.com>2019-03-08 08:59:45 +0100
commitb604e1b12779fec10d783a94ad147fcd81abbc54 (patch)
tree691ea2d827a20b72c44b914101eddd2d250725b5 /source/ap/man-pages/man-pages.SlackBuild
parent3795d8d3c2a562a61c9a35d2dc839405700f3044 (diff)
downloadcurrent-b604e1b12779fec10d783a94ad147fcd81abbc54.tar.gz
current-b604e1b12779fec10d783a94ad147fcd81abbc54.tar.xz
Thu Mar 7 21:26:58 UTC 201920190307212658
a/e2fsprogs-1.44.6-x86_64-1.txz: Upgraded. ap/man-pages-5.00-noarch-1.txz: Upgraded. ap/most-5.1.0-x86_64-1.txz: Upgraded. n/php-7.2.16-x86_64-1.txz: Upgraded. x/xf86-video-amdgpu-19.0.0-x86_64-1.txz: Upgraded. x/xf86-video-ati-19.0.0-x86_64-1.txz: Upgraded. xap/mozilla-thunderbird-60.5.3-x86_64-1.txz: Upgraded. xap/pavucontrol-4.0-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/ap/man-pages/man-pages.SlackBuild')
-rwxr-xr-xsource/ap/man-pages/man-pages.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/source/ap/man-pages/man-pages.SlackBuild b/source/ap/man-pages/man-pages.SlackBuild
index 8d0035849..c44d37fac 100755
--- a/source/ap/man-pages/man-pages.SlackBuild
+++ b/source/ap/man-pages/man-pages.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008-2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008-2019 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=man-pages
-VERSION=${VERSION:-$(echo man-pages-4.*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+VERSION=${VERSION:-$(echo man-pages-5.*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
ARCH=noarch
BUILD=${BUILD:-1}
@@ -43,8 +43,9 @@ mkdir -p $TMP $PKG
cd $TMP
rm -rf man-pages-$VERSION
-tar xf $CWD/man-pages-$VERSION.tar.xz
-tar xf $CWD/man-pages-posix-2013-a.tar.xz
+tar xvf $CWD/man-pages-$VERSION.tar.xz
+tar xvf $CWD/man-pages-posix-2013-a.tar.xz
+echo "Fixing permissions..."
chown -R root:root man-pages-$VERSION man-pages-posix-2013-a
chmod -R a-s,u+rw,go+r-w man-pages-$VERSION man-pages-posix-2013-a
find man-pages-$VERSION \
@@ -78,10 +79,12 @@ rm -f $PKG/usr/man/Makefile
rm -f $PKG/usr/man/Changes.old
# Compress the pages:
+echo "Compressing manpages..."
gzip -9 $PKG/usr/man/man*/*.*
# If a man page exists in some other package, assume that's the
# newer, better version:
+echo "Pruning manpages found in other packages..."
( cd $PKG
for file in usr/man/man*/*.gz ; do
if grep -l $file /var/log/packages/* | grep -v var/log/packages/man-pages ; then
@@ -98,4 +101,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/man-pages-$VERSION-$ARCH-$BUILD.txz
-