summaryrefslogtreecommitdiffstats
path: root/source/a/gpm/gpm.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2013-11-04 17:08:47 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 22:57:36 +0200
commit76fc4757ac91ac7947a01fb7b53dddf9a78a01d1 (patch)
tree9b98e6e193c7870cb27ac861394c1c4592850922 /source/a/gpm/gpm.SlackBuild
parent9664bee729d487bcc0a0bc35859f8e13d5421c75 (diff)
downloadcurrent-76fc4757ac91ac7947a01fb7b53dddf9a78a01d1.tar.gz
current-76fc4757ac91ac7947a01fb7b53dddf9a78a01d1.tar.xz
Slackware 14.1slackware-14.1
Mon Nov 4 17:08:47 UTC 2013 Slackware 14.1 x86_64 stable is released! It's been another interesting release cycle here at Slackware bringing new features like support for UEFI machines, updated compilers and development tools, the switch from MySQL to MariaDB, and many more improvements throughout the system. Thanks to the team, the upstream developers, the dedicated Slackware community, and everyone else who pitched in to help make this release a reality. The ISOs are off to be replicated, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. Please consider supporting the Slackware project by picking up a copy from store.slackware.com. We're taking pre-orders now, and offer a discount if you sign up for a subscription. Have fun! :-)
Diffstat (limited to 'source/a/gpm/gpm.SlackBuild')
-rwxr-xr-xsource/a/gpm/gpm.SlackBuild112
1 files changed, 51 insertions, 61 deletions
diff --git a/source/a/gpm/gpm.SlackBuild b/source/a/gpm/gpm.SlackBuild
index a79ce2b6c..25ac63b03 100755
--- a/source/a/gpm/gpm.SlackBuild
+++ b/source/a/gpm/gpm.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2008, 2009, 2010, 2013 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,8 +22,8 @@
# by: volkerdi@slackware.com
-VERSION=1.20.1
-BUILD=${BUILD:-5}
+VERSION=1.20.7
+BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -54,10 +54,10 @@ rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
-rm -rf gpm-$VERSION
-tar xjvf $CWD/gpm-$VERSION.tar.bz2
-cd gpm-$VERSION
-sed -i -e "s/OPEN_MAX/NR_OPEN/" $(grep -lr OPEN_MAX *)
+rm -rf gpm-$VERSION || exit 1
+tar xvf $CWD/gpm-$VERSION.tar.xz || exit 1
+cd gpm-$VERSION || exit 1
+
chown -R root:root .
find . \
\( -perm 700 -o -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -65,90 +65,80 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-zcat $CWD/gpm-evdev-cumulative.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm.evdevmakefile.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-math.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-weak-wgetch.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-nodebug.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-gpmopen.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-idie.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-subscript.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-input.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-consolename.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-multilib.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-no-console-error.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/gpm-1.20.1-lib-silent.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1.send-noise-to-syslogs.diff.gz | patch -p1 --verbose || exit 1
-zcat $CWD/gpm-1.20.1-input-defines.diff.gz | patch -p1 --verbose || exit 1
+zcat $CWD/gpm-1.20.5-close-fds.patch.gz | patch -p1 --verbose || exit 1
+zcat $CWD/gpm-1.20.1-select-1.patch.gz | patch -p1 --verbose || exit 1
+
+sh autogen.sh
+
+# This is *supposed* to prevent linking libgpm.so with -lncurses,
+# but for some reason it doesn't have the desired effect here.
+# Any ideas? The patch is supposed to resolve a circular dependency
+# between libgpm.so and libncurses.so. I don't notice any ill effects
+# here, but perhaps the problem would occur if prelinking was used.
+# Also, ncurses has not shown an ldd link to libgpm for several releases,
+# so perhaps any problem that existed was fixed on their end.
+# NOTE: Since this isn't preventing gpm from linking to ncurses, I'm
+# commenting this patch out until we understand better if it's even
+# useful for anything. Half a patch seems worse than no patch.
+#zcat $CWD/gpm-1.20.1-weak-wgetch.patch.gz | patch -p1 --verbose || exit 1
+# Since we just patched configure.ac, run this again to carry the change
+# into configure:
autoconf
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- $ARCH-slackware-linux
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+rm -f $PKG/usr/share/emacs/site-lisp/*.elc
+
+chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/libgpm.so.*
+mkdir $PKG/lib${LIBDIRSUFFIX}
+mv $PKG/usr/lib${LIBDIRSUFFIX}/libgpm.so.* $PKG/lib${LIBDIRSUFFIX}
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/libgpm.so
+( cd $PKG/usr/lib${LIBDIRSUFFIX}
+ ln -sf ../../lib${LIBDIRSUFFIX}/libgpm.so.? libgpm.so )
+
zcat $CWD/inputattach.c.gz > inputattach.c
gcc $SLKCFLAGS -o inputattach inputattach.c || exit
-
-mkdir -p $PKG/usr/bin $PKG/etc/rc.d
cat inputattach > $PKG/usr/bin/inputattach
-( cd src
- mkdir -p $PKG/usr/sbin
- cat gpm > $PKG/usr/sbin/gpm
- cat prog/disable-paste > $PKG/usr/bin/disable-paste
- cat prog/gpm-root > $PKG/usr/bin/gpm-root
- cat prog/hltest > $PKG/usr/bin/hltest
- cat prog/mev > $PKG/usr/bin/mev
- cat prog/mouse-test > $PKG/usr/bin/mouse-test
- mkdir -p $PKG/usr/include
- cp headers/gpm.h $PKG/usr/include/gpm.h
- chmod 644 $PKG/usr/include/gpm.h
- mkdir -p $PKG/usr/lib${LIBDIRSUFFIX} $PKG/lib${LIBDIRSUFFIX}
- cat lib/libgpm.a > $PKG/usr/lib${LIBDIRSUFFIX}/libgpm.a
- cat lib/libgpm.so.1.19.0 > $PKG/lib${LIBDIRSUFFIX}/libgpm.so.1.19.0
- chmod 755 $PKG/lib${LIBDIRSUFFIX}/libgpm.so.1.19.0
-)
+
+mkdir -p $PKG/etc/rc.d
+
( cd conf
- mkdir -p $PKG/etc
cat gpm-root.conf > $PKG/etc/gpm-root.conf
cat gpm-syn.conf > $PKG/etc/gpm-syn.conf
cat gpm-twiddler.conf > $PKG/etc/gpm-twiddler.conf
)
-( cd contrib/emacs
- mkdir -p $PKG/usr/share/emacs/site-lisp
- cat t-mouse.el > $PKG/usr/share/emacs/site-lisp/t-mouse.el
-)
+
+mv $PKG/usr/share/{info,man} $PKG/usr
+gzip -9 $PKG/usr/man/man*/*.?
+gzip -9 $PKG/usr/info/*
+
mkdir -p $PKG/usr/doc/gpm-$VERSION
cp -a \
- BUGS COPYING Changelog Changes MANIFEST README TODO \
+ BUGS COPYING* Changelog Changes MANIFEST README* TODO \
+ doc/{Announce,FAQ,HACK_GPM,README*,changelog} \
$PKG/usr/doc/gpm-$VERSION
-( cd doc
- for page in *.1 *.7 *.8 ; do
- CHAPTER=`echo $page | cut -f 2 -d .`
- mkdir -p $PKG/usr/man/man$CHAPTER
- cat $page | gzip -9c > $PKG/usr/man/man${CHAPTER}/$page.gz
- done
- mkdir -p $PKG/usr/info
- cat gpm.info | gzip -9c > $PKG/usr/info/gpm.info.gz
- cp -a \
- Announce FAQ HACK_GPM README* \
- $PKG/usr/doc/gpm-$VERSION
-)
-( cd $PKG/usr/lib${LIBDIRSUFFIX}
- ln -sf ../../lib${LIBDIRSUFFIX}/libgpm.so.1 libgpm.so )
-( cd $PKG/lib${LIBDIRSUFFIX} ; ln -sf libgpm.so.1.19.0 libgpm.so.1 )
+
zcat $CWD/mouseconfig.gz > $PKG/usr/sbin/mouseconfig
chmod 755 $PKG/usr/bin/* $PKG/usr/sbin/*
mkdir -p $PKG/var/log/setup
zcat $CWD/setup.mouse.gz > $PKG/var/log/setup/setup.mouse
chmod 755 $PKG/var/log/setup/setup.mouse
+
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc