summaryrefslogtreecommitdiffstats
path: root/patches/source/old-linux-5.15.139/kernel-modules.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-12-26 00:20:26 +0000
committer Eric Hameleers <alien@slackware.com>2023-12-26 13:30:41 +0100
commit029640d1b850d8ea80bebc33e48b6df6f2678722 (patch)
tree41d7e2ab86b35c558539f168effbd011d7b3bf76 /patches/source/old-linux-5.15.139/kernel-modules.SlackBuild
parentd46ef1440f426d37b8e6935991e5c5808e558d66 (diff)
downloadcurrent-9c047f50459ff0190d76e82192250cc29d984898.tar.gz
current-9c047f50459ff0190d76e82192250cc29d984898.tar.xz
Tue Dec 26 00:20:26 UTC 202320231226002026_15.0
patches/packages/kernel-firmware-20231222_a7dee43-noarch-1.txz: Upgraded. Updated to the latest kernel firmware. patches/packages/linux-5.15.145/*: Upgraded. These updates fix various bugs and security issues. Thanks to jwoithe for the PCI fix! Be sure to upgrade your initrd after upgrading the kernel packages. If you use lilo to boot your machine, be sure lilo.conf points to the correct kernel and initrd and run lilo as root to update the bootloader. If you use elilo to boot your machine, you should run eliloconfig to copy the kernel and initrd to the EFI System Partition. For more information, see: Fixed in 5.15.140: https://www.cve.org/CVERecord?id=CVE-2023-46862 Fixed in 5.15.141: https://www.cve.org/CVERecord?id=CVE-2023-6121 (* Security fix *)
Diffstat (limited to 'patches/source/old-linux-5.15.139/kernel-modules.SlackBuild')
-rwxr-xr-xpatches/source/old-linux-5.15.139/kernel-modules.SlackBuild146
1 files changed, 146 insertions, 0 deletions
diff --git a/patches/source/old-linux-5.15.139/kernel-modules.SlackBuild b/patches/source/old-linux-5.15.139/kernel-modules.SlackBuild
new file mode 100755
index 000000000..d7df6d3c4
--- /dev/null
+++ b/patches/source/old-linux-5.15.139/kernel-modules.SlackBuild
@@ -0,0 +1,146 @@
+#!/bin/sh
+
+# Copyright 2018, 2020, 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# To use this script, point it to a Linux kernel source tree and a .config
+# file by setting the appropriate environment variables:
+#
+# KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild
+#
+# By default, it will use the source and .config already in /usr/src/linux (if possible).
+
+# KERNEL_NAME is optional, and we don't use it. Define it to "-name" if
+# you'd like an extra string after "kernel" in the package name
+# (i.e. "kernel-name-modules").
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+KERNEL_NAME=${KERNEL_NAME:-}
+KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
+KERNEL_CONFIG=${KERNEL_CONFIG:-/usr/src/linux/.config}
+BUILD=${BUILD:-1}
+
+# The CONFIG_DEBUG_INFO_BTF_MODULES option adds a huge amount of debugging
+# data to the modules which we don't actually need. We'll strip debugging
+# information from kernel modules by default. If you are building a debug
+# kernel and wish to retain this data, export the variable below set to "NO".
+STRIP_DEBUG=${STRIP_DEBUG:-YES}
+
+if [ ! -r "${KERNEL_CONFIG}" ]; then
+ echo "Error: the KERNEL_CONFIG environment variable needs to be set to the"
+ echo ".config file to be used to build these modules. Example:"
+ echo "KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild"
+ exit 1
+fi
+if [ ! -d "${KERNEL_SOURCE}" ]; then
+ echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
+ exit 1
+fi
+# Get the kernel version from the kernel Makefile:
+VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
+# Set LOCALVERSION to the value found inside the .config:
+LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ # We will need to copy the config and run make oldconfig and make
+ # prepare in order to generate kernel/bounds.s, where we can find
+ # the true $PACKAGE_ARCH.
+ if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
+ cp -a ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
+ fi
+ cd ${KERNEL_SOURCE}
+ make oldconfig 1> /dev/null 2> /dev/null
+ make prepare 1> /dev/null 2> /dev/null
+ PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
+ echo "kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz"
+ exit 0
+fi
+
+NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-kernel${KERNEL_NAME}-modules
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+
+# Set the variable $KERNEL_CLEAN to anything to run "make clean" before the
+# build. Default is to start compiling in the tree as we found it.
+if [ ! -z "${KERNEL_CLEAN}" ]; then
+ ( cd ${KERNEL_SOURCE}
+ echo "Cleaning kernel source (make clean)..."
+ make clean
+ # Make sure header files aren't missing...
+ make prepare
+ # Don't package the kernel in the sources:
+ find . -name "*Image" -exec rm "{}" \+
+ # No need for these:
+ rm -f .config.old .version
+ find . -name "*.cmd" -exec rm -f "{}" \+
+ rm .*.d
+ )
+fi
+
+# Copy the .config into the kernel source directory (unless it's there already)
+if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
+ echo "Copying the .config file to the kernel source tree:"
+ cp -a --verbose ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
+fi
+
+( cd ${KERNEL_SOURCE}
+ echo "Running make oldconfig..."
+ make oldconfig
+ echo "Running a preliminary make (needed to create modules.builtin.modinfo)..."
+ make $NUMJOBS || exit 1
+ echo "Building kernel modules..."
+ make $NUMJOBS modules || exit 1
+ echo "Installing kernel modules to $PKG..."
+ make INSTALL_MOD_PATH=$PKG modules_install || exit 1
+ if [ "$STRIP_DEBUG" = "YES" ]; then
+ echo "Stripping debug info from kernel modules..."
+ find $PKG -name "*.ko" -exec strip --strip-debug "{}" \;
+ fi
+ # Fix build and source symlinks if they are pointing into $TMP:
+ ( cd $PKG/lib/modules/${VERSION}${LOCALVERSION}
+ for symlink in build source ; do
+ target=$(readlink $symlink)
+ if echo $target | grep -q "^$TMP/package-kernel-source/" ; then
+ rm -f $symlink
+ ln -sf $(echo $target | sed "s|$TMP/package-kernel-source/|/|g") $symlink
+ fi
+ done
+ )
+ depmod -b $PKG -a ${VERSION}${LOCALVERSION}
+) || exit 1
+
+mkdir $PKG/install
+cat $CWD/slack-desc/slack-desc.kernel-modules-template | sed "s/%PACKAGE_NAME%/kernel${KERNEL_NAME}-modules${LOCALVERSION}/g" > $PKG/install/slack-desc
+
+# Fetch the kernel architecture from the source tree:
+cd ${KERNEL_SOURCE}
+PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
+
+# Make the package:
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz
+