summaryrefslogtreecommitdiffstats
path: root/vlc/build/vlc.SlackBuild
diff options
context:
space:
mode:
author Eric Hameleers <alien@slackware.com>2017-05-25 10:19:09 +0000
committer Eric Hameleers <alien@slackware.com>2017-05-25 10:19:09 +0000
commit796b8c5d9e79b5d1dab0740672a0f97f8ff5e265 (patch)
treec534740cb2f61ae631c53babd62732a187c430a3 /vlc/build/vlc.SlackBuild
parent80e9dcaf99a2b5575f850e69d2b093a5e6151612 (diff)
downloadasb-796b8c5d9e79b5d1dab0740672a0f97f8ff5e265.tar.gz
asb-796b8c5d9e79b5d1dab0740672a0f97f8ff5e265.tar.xz
vlc: updated to 2.2.5.1 along with updates to internal libraries like libass, libbluray, libdvdcss, glew, libva, live, mpcdec, opus, speex, libvpx, x262, x264, x265
Diffstat (limited to 'vlc/build/vlc.SlackBuild')
-rwxr-xr-xvlc/build/vlc.SlackBuild156
1 files changed, 81 insertions, 75 deletions
diff --git a/vlc/build/vlc.SlackBuild b/vlc/build/vlc.SlackBuild
index e2f839a7..fa6f42d7 100755
--- a/vlc/build/vlc.SlackBuild
+++ b/vlc/build/vlc.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
# $Id$
-# Copyright 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016 Eric Hameleers, Eindhoven, Netherlands
+# Copyright 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2017 Eric Hameleers, Eindhoven, Netherlands
#
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
@@ -417,6 +417,11 @@
# * New release.
# 2.2.2-2 22/feb/2016 by Eric Hameleers <alien@slackware.com>
# * Rebuilt slackware-current version without Qt5 dependency.
+# 2.2.4-1 07/jul/2016 by Eric Hameleers <alien@slackware.com>
+# * Update. New versions of internal support libraries: x262,
+# opus, libva and libmpcdec.
+# 2.2.5.1-1 24/may/2017 by Eric Hameleers <alien@slackware.com>
+# * Update.
#
# Run 'sh vlc.SlackBuild' to build a Slackware package.
# The package (.txz) plus descriptive .txt file are created in /tmp .
@@ -440,7 +445,7 @@
PRGNAM=vlc
PRGNAM2=npapi-vlc
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
NPBUILD=${NPBUILD:-1}
TAG=${TAG:-"alien"}
@@ -469,7 +474,7 @@ SLACKVER=${SLACKVER:-$(cat /etc/slackware-version| cut -d' ' -f2)}
#DEFGITURI=${GITURI:-"git://git.videolan.org/vlc.git"}
DEFGITURI=${GITURI:-"git://git.videolan.org/vlc/vlc-2.2.git"}
-VERSION=${VERSION:-"2.2.2"}
+VERSION=${VERSION:-"2.2.5.1"}
DOCS="ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS README THANKS"
@@ -487,7 +492,7 @@ if [ -z "$ARCH" ]; then
fi
case "$ARCH" in
- i486) SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ i?86) SLKCFLAGS="-O2 -march=${ARCH} -mtune=i686"
SLKLDFLAGS=""; LIBDIRSUFFIX=""
;;
x86_64) SLKCFLAGS="-O2 -fPIC"
@@ -556,6 +561,13 @@ STATIC_FFMPEG=$(echo $STATIC_FFMPEG | tr 'a-z' 'A-Z')
MOZPLUGIN=${MOZPLUGIN:-"YES"}
MOZPLUGIN=$(echo $MOZPLUGIN | tr 'a-z' 'A-Z')
+# Explicitly enable pulseaudio or it will not be picked up by ffmpeg:
+if pkg-config --exists libpulse 2>/dev/null ; then
+ USE_PULSE="--enable-libpulse"
+else
+ USE_PULSE=""
+fi
+
# -----------------------------------------------------------------------------
# We're done with the initials. Let's move on:
# -----------------------------------------------------------------------------
@@ -566,9 +578,9 @@ AACENC=0.1.2
AMRWBENC=0.1.3
AMR=0.1.3
ASDCPLIB=1.12.58
-ASS=0.13.0
+ASS=0.13.6
AVC1394=0.5.4
-BLURAY=0.9.2
+BLURAY=1.0.0
CDDB=1.3.2
CDIO=0.90
DAAP=0.4.0
@@ -578,7 +590,7 @@ DV=1.0.0
DVBPSI=1.3.0
DVDNAV=5.0.3
DVDREAD=5.0.3
-DVDCSS=1.3.99
+DVDCSS=1.4.0
EBML=1.3.3
FAAC=1.28
FAAD2=2.7
@@ -587,26 +599,26 @@ FLUID=1.1.6
FRIBIDI=0.19.7
GGI=2.2.2
GII=1.0.2
-GLEW=1.7.0
+GLEW=2.0.0
GOOM=2k4-0
-GSM=1.0.13
+GSM=1.0.16
KATE=0.4.1
LAME=3.99.5
-LIBVA=1.6.1
-LIVE=2016.01.12
+LIBVA=1.6.2
+LIVE=2016.02.22
LUA=5.1.5
MATROSKA=1.4.4
-MPCDEC=r475
+MPCDEC=r481
MPEG2DEC=0.5.1
-NPAPI=20160209
-OPUS=1.1.1
-ORC=0.4.18
+NPAPI=20170523
+OPUS=1.1.4
+ORC=0.4.26
PROJECTM=2.0.1
-QT4=4.8.5
+QT4=4.8.6
RAW1394=2.0.5
SCHROEDINGER=1.0.11
SHOUT=2.4.1
-SPEEX=1.2rc2
+SPEEX=1.2.0
SPEEXDSP=1.2rc3
TAGLIB=1.9.1
THEORA=1.1.1
@@ -615,10 +627,10 @@ TWOLAME=0.3.13
UPNP=1.6.19
VCD=0.7.24
VDPAU=1.1.1
-VPX=1.5.0
-X262=20160209
-X264=20160209-2245
-X265=1.9
+VPX=1.6.1
+X262=20170523
+X264=20170523-2245
+X265=2.4
# Determine what X we're running (the modular X returns the prefix
# in the next command, while older versions stay silent):
@@ -720,7 +732,7 @@ USE[5]="YES"
# Lame is used for the audio in FLV videos; will statically link with ffmpeg
SOURCE[6]="$SRCDIR/lame-$LAME.tar.gz"
SRCURL[6]="http://downloads.sourceforge.net/lame/lame-$LAME.tar.gz"
-SRCPAT[6]="YES"
+SRCPAT[6]="NO"
USE[6]="YES"
# DV video, used by most digital (firewire) camcorders:
@@ -796,15 +808,14 @@ SRCPAT[18]="NO"
USE[18]="YES"
# Musepack (MPC) audio demuxing support:
-SOURCE[19]="$SRCDIR/libmpcdec-${MPCDEC}.tar.bz2"
-#SRCURL[19]="http://files.musepack.net/source/libmpcdec-${MPCDEC}.tar.bz2"
-SRCURL[19]=""
+SOURCE[19]="$SRCDIR/libmpcdec-${MPCDEC}.tar.gz"
+SRCURL[19]="http://download.videolan.org/pub/contrib/musepack_src_${MPCDEC}.tar.gz"
SRCPAT[19]="NO"
USE[19]="YES"
# Orc (oil runtime compiler) is a dependency for schroedinger
-SOURCE[20]="$SRCDIR/orc-${ORC}.tar.gz"
-SRCURL[20]="http://download.videolan.org/pub/contrib/orc-${ORC}.tar.gz"
+SOURCE[20]="$SRCDIR/orc-${ORC}.tar.xz"
+SRCURL[20]="https://gstreamer.freedesktop.org/src/orc/orc-${ORC}.tar.xz"
SRCPAT[20]="NO"
USE[20]="YES"
@@ -969,8 +980,8 @@ SRCPAT[46]="NO"
USE[46]="YES"
# The browser plugin source has been separated from VLC:
-SOURCE[47]="$SRCDIR/npapi-vlc-${NPAPI}.tar.xz"
-#SRCURL[47]="http://download.videolan.org/pub/videolan/vlc/${NPAPI}/npapi-vlc-${NPAPI}.tar.xz"
+SOURCE[47]="$SRCDIR/npapi-vlc-${NPAPI}.tar.gz"
+#SRCURL[47]="https://code.videolan.org/videolan/npapi-vlc/repository/archive.tar.gz?ref=${NPAPI}"
SRCURL[47]=""
SRCPAT[47]="NO"
USE[47]="YES"
@@ -1146,16 +1157,6 @@ src_checkout() {
&& tar --exclude .git -${TARCOMP}cf ${2} npapi-vlc-${NPAPI}
rm -rf npapi-vlc-${NPAPI}
;;
- 47) # We clone the git of npapi-vlc at a certain date:
- mkdir npapi-vlc-${NPAPI} \
- && cd npapi-vlc-${NPAPI} \
- && git clone git://git.videolan.org/npapi-vlc.git . \
- && git checkout $(git rev-list -n 1 --before="`date -d $NPAPI`" master) \
- && chown -R root:root . \
- && cd .. \
- && tar --exclude .git -${TARCOMP}cf ${2} npapi-vlc-${NPAPI}
- rm -rf npapi-vlc-${NPAPI}
- ;;
48) # We clone the git of libbluray at a certain date:
mkdir libbluray-${BLURAY} \
&& cd libbluray-${BLURAY} \
@@ -1194,7 +1195,7 @@ src_checkout() {
if [ "${USE_PATENTS}" == "YES" ]; then
echo ""
echo "**"
- echo "** This build uses patented code (MP3 / AMR / AAC encoders)"
+ echo "** This build uses patented code (AAC encoder)"
echo "** Run the command 'USE_PATENTS=NO $0 $*' to avoid patent issues."
echo "**"
echo ""
@@ -1404,7 +1405,7 @@ if [ "$(gcc --version|grep '^gcc'|cut -d' ' -f3|cut -d. -f1,2)" = "4.9" ]; then
fi
# Fix compilation on x86 (xmmintrin.h error: inlining failed)
-cat $SRCDIR/lame_x86-xmmintrin.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/lame_x86-xmmintrin.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_lame.log
CFLAGS="$SLKCFLAGS" \
@@ -1439,7 +1440,7 @@ echo -e "**\n** faac ...\n**"
cd $TMP/tmp-$PRGNAM/faac-$FAAC
# Newer gcc/glibc will bail out otherwise:
-cat $SRCDIR/faac_gcc44.diff | patch -p1 --verbose \
+cat $SRCDIR/patches/faac_gcc44.diff | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_faac.log
#sh bootstrap
@@ -1605,8 +1606,7 @@ fi
# Only use patented code if we are allowing it:
if [ "${USE_PATENTS}" == "YES" ]; then
- USE_PATENTED="--enable-libmp3lame \
- --enable-libfaac \
+ USE_PATENTED="--enable-libfaac \
--enable-libvo-aacenc \
--enable-nonfree"
else
@@ -1618,7 +1618,10 @@ cd $TMP/tmp-$PRGNAM/ffmpeg-${FFMPEG}
# Apply patches:
touch $OUTPUT/patch-${PRGNAM}_ffmpeg.log
# Adjust for the newer libvpx:
-cat $SRCDIR/ffmpeg_vpx_removed_ids.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/ffmpeg_vpx_removed_ids.patch | patch -p1 --verbose \
+ 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_ffmpeg.log
+# Prevent a segfault:
+cat $SRCDIR/patches/ffmpeg_xwd_segfault.patch | patch -p1 --verbose \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_ffmpeg.log
if [ "$ARCH" = "x86_64" ]; then
@@ -1646,6 +1649,7 @@ PKG_CONFIG_PATH="${VLCDEPSDIR}/usr/lib${LIBDIRSUFFIX}/pkgconfig" \
--libdir=$VLCDEPSDIR/usr/lib${LIBDIRSUFFIX} \
--shlibdir=$VLCDEPSDIR/usr/lib${LIBDIRSUFFIX} \
${USE_PATENTED} \
+ ${USE_PULSE} \
--disable-avdevice \
--disable-avfilter \
--disable-avresample \
@@ -1662,6 +1666,7 @@ PKG_CONFIG_PATH="${VLCDEPSDIR}/usr/lib${LIBDIRSUFFIX}/pkgconfig" \
--enable-gpl \
--enable-version3 \
--enable-libgsm \
+ --enable-libmp3lame \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
--enable-libtheora \
@@ -2004,7 +2009,7 @@ cd -
make_mpcdec()
{
echo -e "**\n** libmpcdec ...\n**"
-cd $TMP/tmp-$PRGNAM/libmpcdec-$MPCDEC
+cd $TMP/tmp-$PRGNAM/musepack_src_$MPCDEC
# Prevent a dependency on libreplaygain and libcuefile:
sed -i \
@@ -2217,7 +2222,7 @@ echo -e "**\n** libcdio ...\n**"
DO_VCD=${1:-" "}
cd $TMP/tmp-$PRGNAM/libcdio-$CDIO
## Patch that allows vlc to detect required libs for cdio:
-#cat $SRCDIR/libcdio-0.80_Makefile.patch | patch -p0 --verbose \
+#cat $SRCDIR/patches/libcdio-0.80_Makefile.patch | patch -p0 --verbose \
# 2>1 | tee -a $OUTPUT/patch-${PRGNAM}.log
## Because of patching a .am file, need to reconf:
#autoreconf -vif
@@ -2349,9 +2354,13 @@ make_upnp()
echo -e "**\n** libupnp ...\n**"
cd $TMP/tmp-$PRGNAM/libupnp-$UPNP
+touch $OUTPUT/patch-${PRGNAM}_upnp.log
# Fix the compilation and avoid undefined symbols afterwards:
-cat $SRCDIR/libupnp_miniserver.patch | patch -p1 --verbose \
- 2>&1 | tee $OUTPUT/patch-${PRGNAM}_upnp.log
+cat $SRCDIR/patches/libupnp_miniserver.patch | patch -p1 --verbose \
+ 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_upnp.log
+# Fix some libupnp bugs:
+cat $SRCDIR/patches/libupnp_fix_infinite_loop.patch | patch -p1 --verbose \
+ 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_upnp.log
CFLAGS="$SLKCFLAGS -DUPNP_STATIC_LIB" \
CXXFLAGS="$SLKCFLAGS -DUPNP_STATIC_LIB" \
@@ -2392,7 +2401,7 @@ echo -e "**\n** orc ...\n**"
cd $TMP/tmp-$PRGNAM/orc-$ORC
## Make the static build succeed:
-#cat $SRCDIR/orc-0.4.3_static.diff | patch -p1 --verbose \
+#cat $SRCDIR/patches/orc-0.4.3_static.diff | patch -p1 --verbose \
# 2>&1 | tee $OUTPUT/patch-${PRGNAM}_orc.log
CFLAGS="$SLKCFLAGS" \
@@ -2433,7 +2442,7 @@ else
fi
cd $TMP/tmp-$PRGNAM/schroedinger-$SCHROEDINGER
-cat $SRCDIR/schroedinger_notests.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/schroedinger_notests.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_schroedinger.log
# Since the patch touches Makefile.am we have to reconfigure:
@@ -2480,9 +2489,9 @@ echo -e "**\n** speex ...\n**"
cd $TMP/tmp-$PRGNAM/speex-$SPEEX
## We are using a git tarball now, we need to accommodate a bit:
-#cat $SRCDIR/speex_automake.patch | patch -p1 --verbose \
+#cat $SRCDIR/patches/speex_automake.patch | patch -p1 --verbose \
# 2>&1 | tee $OUTPUT/patch-${PRGNAM}_speex.log
-#cat $SRCDIR/speex_no-ogg.patch | patch -p1 --verbose \
+#cat $SRCDIR/patches/speex_no-ogg.patch | patch -p1 --verbose \
# 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_speex.log
#
#autoreconf -vif
@@ -2591,15 +2600,15 @@ find $TMP/tmp-$PRGNAM/goom${GOOM} -type d -exec chmod 755 {} \;
cd $TMP/tmp-$PRGNAM/goom${GOOM}
# I think MMX is crashing the goom plugin on 32-bit:
-cat $SRCDIR/goom-2k4-0.nommx.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/goom-2k4-0.nommx.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_goom.log
# Do not install the xmms plugin to the root filesystem:
-cat $SRCDIR/goom2k4-xmmslibdir.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/goom2k4-xmmslibdir.patch | patch -p1 --verbose \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_goom.log
# Do not build the xmms plugin in the first place (GTK related errors):
-cat $SRCDIR/goom-2k4-0.noxmms.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/goom-2k4-0.noxmms.patch | patch -p1 --verbose \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_goom.log
# Eliminate a double include:
@@ -2669,7 +2678,7 @@ echo -e "**\n** projectm ...\n**"
cd $TMP/tmp-$PRGNAM/projectM-${PROJECTM}-Source
# Fix linking - get rid of unresolved symbols at runtime:
-cat $SRCDIR/projectM_static.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/projectM_static.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_projectm.log
# We need to redefine the presets etc path:
@@ -3009,7 +3018,7 @@ OLDDIR=$(pwd)
cd $TMP/tmp-$PRGNAM/libraw1394-${RAW1394}
# Or else vlc compilation fails with "error: redefinition of typedef 'byte_t'"
-patch -p0 --verbose < $SRCDIR/libraw1394_typedef.patch \
+patch -p0 --verbose < $SRCDIR/patches/libraw1394_typedef.patch \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}_raw1394.log
[ ! -x configure ] && ./autogen.sh
@@ -3069,7 +3078,7 @@ echo -e "**\n**"
cd $TMP/tmp-$PRGNAM/libdc1394-${DC1394}
## Skip building the examples - those cause errors:
-#cat $SRCDIR/libdc1394-noexamples.patch | patch -p1 --verbose \
+#cat $SRCDIR/patches/libdc1394-noexamples.patch | patch -p1 --verbose \
# 2>&1 | tee $OUTPUT/patch-${PRGNAM}_dc1394.log
# Make sure that the static libdc1394 is found in the vlcdeps:
@@ -3118,7 +3127,7 @@ else
fi
# Allow for internal use of the library:
-cat $SRCDIR/fribidi.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/fribidi.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_fribidi.log
# Fix error on Slackware 14.1, no issue on Slackware 14.2...
@@ -3163,7 +3172,7 @@ echo -e "**\n** ass ...\n**"
cd $TMP/tmp-$PRGNAM/libass-$ASS
## Make it find libiconv if present:
-#cat $SRCDIR/libass_fix_iconv.patch | patch -p1 --verbose \
+#cat $SRCDIR/patches/libass_fix_iconv.patch | patch -p1 --verbose \
# 2>&1 | tee $OUTPUT/patch-${PRGNAM}_ass.log
# And since we patched the configure:
@@ -3269,7 +3278,7 @@ echo -e "**\n** kate ...\n**"
cd $TMP/tmp-$PRGNAM/libkate-${KATE}
## Compatibility patch for libpng14:
-#cat $SRCDIR/libkate_png14.patch | patch -p0 --verbose \
+#cat $SRCDIR/patches/libkate_png14.patch | patch -p0 --verbose \
# 2>&1 | tee $OUTPUT/patch-${PRGNAM}_kate.log
CFLAGS="$SLKCFLAGS" \
@@ -3343,7 +3352,7 @@ cd $TMP/tmp-$PRGNAM/lua-${LUA}
# Use 32-bits LUAC file format on all platforms. In other words,
# 64-bits platform will support 32-bits LUAC files and reject 64-bits LUAC
# files. This should ease cross-compilation and copying luac files manually.
-cat $SRCDIR/luac-32bits.patch | patch -p1 --verbose \
+cat $SRCDIR/patches/luac-32bits.patch | patch -p1 --verbose \
2>&1 | tee $OUTPUT/patch-${PRGNAM}_lua.log
# Make it use our CFLAGS:
@@ -3480,7 +3489,7 @@ case "$ARCH" in
;;
armv7hl)
ARCHOPTS="--target=armv7-linux-gcc --enable-pic"
- cat $SRCDIR/libvpx_fix-armhf-link.patch | patch -p1 --verbose
+ cat $SRCDIR/patches/libvpx_fix-armhf-link.patch | patch -p1 --verbose
export AS=as
export AR=ar
export CROSS="${TARGET}-"
@@ -3565,7 +3574,7 @@ cd -
make_npapi()
{
echo -e "**\n** npapi ...\n**"
-cd $TMP/tmp-$PRGNAM/$PRGNAM2-${NPAPI}
+cd $TMP/tmp-$PRGNAM/$PRGNAM2-${NPAPI}*
[ ! -x configure ] && ./autogen.sh 2>&1 | tee autogen-${PRGNAM}_npapi.log
@@ -3746,7 +3755,7 @@ cd $TMP/tmp-$PRGNAM/${PRGNAM}-${SRCVER}
echo "" >$OUTPUT/patch-${PRGNAM}.log
## Configure a default Slackware TTF font:
-#cat $SRCDIR/vlc-2.2_deffont.patch | patch -p1 --verbose \
+#cat $SRCDIR/patches/vlc-2.2_deffont.patch | patch -p1 --verbose \
# 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}.log
# Fix SDL header location:
@@ -3761,14 +3770,14 @@ fi
# Only include libs for patented codecs if we are allowing/needing it:
if [ "${USE_PATENTS}" == "YES" -a "$STATIC_FFMPEG" == "YES" ]; then
- DO_FFMPEG_LIBS_PAT="-lmp3lame -lfaac"
+ DO_FFMPEG_LIBS_PAT="-lfaac"
else
DO_FFMPEG_LIBS_PAT=""
fi
## FFMPEG changed it's CPU flag definitions but VLC did not yet follow:
#if grep -q FF_MM_MMX modules/stream_out/switcher.c ; then
-# cat $SRCDIR/vlc_ffmpeg_mm_api.patch | patch -p1 --verbose \
+# cat $SRCDIR/patches/vlc_ffmpeg_mm_api.patch | patch -p1 --verbose \
# 2>&1 | tee -a $OUTPUT/patch-${PRGNAM}.log
#fi
@@ -3792,14 +3801,14 @@ fi
# Plug a xss vulnerability, commited right after 2.0.6:
if [ "$VERSION" = "2.0.6" ]; then
- cat $SRCDIR/vlc-2.0.6_xss_vulns.patch | patch -p1 --verbose \
+ cat $SRCDIR/patches/vlc-2.0.6_xss_vulns.patch | patch -p1 --verbose \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}.log
fi
# avcodec audio decoder: update block pointer (emergency patch for 2.0.8
# after which a new 2.0.8a tarball was released):
if [ "$VERSION" = "2.0.8" ]; then
- cat $SRCDIR/vlc-2.0.8_update_block_pointer.patch | patch -p1 --verbose \
+ cat $SRCDIR/patches/vlc-2.0.8_update_block_pointer.patch | patch -p1 --verbose \
2>&1 | tee -a $OUTPUT/patch-${PRGNAM}.log
fi
@@ -4092,10 +4101,7 @@ cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION || true
cp -a $VLCDEPSDIR/doc/* $PKG/usr/doc/$PRGNAM-$VERSION || true
# Add the SlackBuild as well as all patches we used to create the package:
cat $SRCDIR/$(basename $0) > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-( cd $SRCDIR
- tar -zcf $PKG/usr/doc/$PRGNAM-$VERSION/${PRGNAM}_slackware_patches.tar.gz \
- *.diff *.patch
-)
+cp -a $SRCDIR/patches $PKG/usr/doc/$PRGNAM-$VERSION/
find $PKG/usr/doc -type f -exec chmod 644 {} \;
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/*
@@ -4197,9 +4203,9 @@ else
make_amr
make_amrwbenc
make_gsm
+ make_lame
# Only use patented code if we are allowing it:
if [ "${USE_PATENTS}" == "YES" ]; then
- make_lame
make_faac
make_aacenc
fi