summaryrefslogtreecommitdiffstats
path: root/rawtherapee/build/rawtherapee.SlackBuild
diff options
context:
space:
mode:
author Eric Hameleers <alien@slackware.com>2012-02-23 21:32:42 +0000
committer Eric Hameleers <alien@slackware.com>2012-02-23 21:32:42 +0000
commitd875079c2b906a0a4a9d30862b0779701eb290f3 (patch)
tree4a4a8a8949aa8d4655829a2c6ccdb565f52ecfe7 /rawtherapee/build/rawtherapee.SlackBuild
parentbcd3c2ac0759a3302256cd7069f41517298ef978 (diff)
downloadasb-d875079c2b906a0a4a9d30862b0779701eb290f3.tar.gz
asb-d875079c2b906a0a4a9d30862b0779701eb290f3.tar.xz
Update to 4.0.7 tarball
Diffstat (limited to '')
-rwxr-xr-xrawtherapee/build/rawtherapee.SlackBuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/rawtherapee/build/rawtherapee.SlackBuild b/rawtherapee/build/rawtherapee.SlackBuild
index 9e56bcf0..91ae151e 100755
--- a/rawtherapee/build/rawtherapee.SlackBuild
+++ b/rawtherapee/build/rawtherapee.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
# $Id$
-# Copyright 2011 Eric Hameleers, Eindhoven, NL
+# Copyright 2011, 2012 Eric Hameleers, Eindhoven, NL
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
@@ -33,6 +33,8 @@
# 3.0.0-1: 12/Aug/2011 by Eric Hameleers <alien@slackware.com>
# * Initial build. No official source release, so I have to
# checkout from a mercurial branch.
+# 4.0.7-1: 22/feb/2012 by Eric Hameleers <alien@slackware.com>
+# * Build an official tarball.
#
# Run 'sh rawtherapee.SlackBuild' to build a Slackware package.
# The package (.tgz) and .txt file as well as build logs are created in /tmp .
@@ -43,7 +45,7 @@
# Set initial variables:
PRGNAM=rawtherapee
-VERSION=${VERSION:-3.0}
+VERSION=${VERSION:-4.0.7}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:" -j4 "}
TAG=${TAG:-alien}
@@ -61,7 +63,7 @@ OUTPUT=${OUTPUT:-/tmp}
# If you want automatic download to work, supply a URL for 'SRCURL' below:
SOURCE="$SRCDIR/${PRGNAM}-${VERSION}.tar.xz"
-SRCURL=""
+SRCURL="http://rawtherapee.googlecode.com/files/$PRGNAM-$VERSION.tar.xz"
# Use the src_checkout() function if no downloadable tarball exists.
# This function checks out sources from SVN/CVS and creates a tarball of them.
@@ -117,12 +119,14 @@ src_checkout() {
##
# Automatically determine the architecture we're building on:
+MARCH=$( uname -m )
if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
+ case "$MARCH" in
+ i?86) export ARCH=i486 ;;
+ armv7hl) export ARCH=$MARCH ;;
+ arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$( uname -m ) ;;
+ *) export ARCH=$MARCH ;;
esac
fi
@@ -133,6 +137,9 @@ case "$ARCH" in
x86_64) SLKCFLAGS="-O2 -fPIC"
SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
;;
+ armv7h)l SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
+ SLKLDFLAGS=""; LIBDIRSUFFIX=""
+ ;;
*) SLKCFLAGS="-O2"
SLKLDFLAGS=""; LIBDIRSUFFIX=""
;;
@@ -203,8 +210,10 @@ cd ${PRGNAM}-${VERSION}
sed -i -e "s|install (PROGRAMS rtstart|\#install (PROGRAMS rtstart|" \
CMakeLists.txt
-# Define variables taken from the mercury repository at checkout:
-eval $(cat slackinfo)
+if [ ! -n "$SRCURL" ]; then
+ # Define variables taken from the mercury repository at checkout:
+ eval $(cat slackinfo)
+fi
chown -R root:root .
chmod -R u+w,go+r-w,a+X-s .