summaryrefslogtreecommitdiffstats
path: root/system/OpenSnitch
diff options
context:
space:
mode:
Diffstat (limited to 'system/OpenSnitch')
-rw-r--r--system/OpenSnitch/OpenSnitch.SlackBuild11
-rw-r--r--system/OpenSnitch/OpenSnitch.info26
-rw-r--r--system/OpenSnitch/modules.txt20
-rw-r--r--system/OpenSnitch/patches/modify-go.mod-file.patch22
4 files changed, 43 insertions, 36 deletions
diff --git a/system/OpenSnitch/OpenSnitch.SlackBuild b/system/OpenSnitch/OpenSnitch.SlackBuild
index 7d8ac974a8..af781b6d62 100644
--- a/system/OpenSnitch/OpenSnitch.SlackBuild
+++ b/system/OpenSnitch/OpenSnitch.SlackBuild
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=OpenSnitch
-VERSION=${VERSION:-1.6.5.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.6.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -119,9 +119,6 @@ sed -i 's/^import ui_pb2/from . import ui_pb2/' ui/opensnitch/ui_pb2_grpc.py
# prefer scaled SVG instead of pixellated 48x48 PNG
patch -p1 < $CWD/patches/fix-setup.py.patch
-# Modify the go.mod file for the offline build
-patch -p1 < $CWD/patches/modify-go.mod-file.patch
-
# Remove debian patch
patch -p1 < $CWD/patches/remove-debian-path.patch
@@ -152,6 +149,8 @@ do
tar xvf $CWD/$NAME-[a-z]*.tar.gz
elif [ $DIR = "vendor/google.golang.org/genproto" ]; then
tar xvf $CWD/go-$NAME-*.tar.gz
+ elif [ $DIR = "vendor/honnef.co/go/tools" ]; then
+ tar xvf $CWD/go-tools-*.tar.gz
elif [ $DIR = "vendor/google.golang.org/protobuf" ]; then
tar xvf $CWD/$NAME-go-*.tar.gz
else
@@ -160,7 +159,7 @@ do
# Rename extracted folders
mkdir -p $(dirname $DIR)
- [ $DIR = "vendor/google.golang.org/genproto" ] && mv go-$NAME-* $DIR || mv $NAME-* $DIR
+ [ $DIR = "vendor/google.golang.org/genproto" ] || [ $DIR = "vendor/honnef.co/go/tools" ] && mv go-$NAME-* $DIR || mv $NAME-* $DIR
done
# Build the opensnitch daemon
diff --git a/system/OpenSnitch/OpenSnitch.info b/system/OpenSnitch/OpenSnitch.info
index 646d9a360f..b9dbc346c7 100644
--- a/system/OpenSnitch/OpenSnitch.info
+++ b/system/OpenSnitch/OpenSnitch.info
@@ -1,7 +1,7 @@
PRGNAM="OpenSnitch"
-VERSION="1.6.5.1"
+VERSION="1.6.6"
HOMEPAGE="https://github.com/evilsocket/opensnitch"
-DOWNLOAD="https://github.com/evilsocket/opensnitch/archive/v1.6.5.1/opensnitch-1.6.5.1.tar.gz \
+DOWNLOAD="https://github.com/evilsocket/opensnitch/archive/v1.6.6/opensnitch-1.6.6.tar.gz \
https://github.com/fsnotify/fsnotify/archive/v1.4.7/fsnotify-1.4.7.tar.gz \
https://github.com/golang/protobuf/archive/v1.5.0/protobuf-1.5.0.tar.gz \
https://github.com/google/gopacket/archive/v1.1.14/gopacket-1.1.14.tar.gz \
@@ -16,11 +16,17 @@ DOWNLOAD="https://github.com/evilsocket/opensnitch/archive/v1.6.5.1/opensnitch-1
https://github.com/vishvananda/netns/archive/db3c7e5/netns-db3c7e526aae966c4ccfa6c8189b693d6ac5d202.tar.gz \
https://github.com/golang/net/archive/491a49a/net-491a49abca63de5e07ef554052d180a1b5fe2d70.tar.gz \
https://github.com/golang/sys/archive/97ca703/sys-97ca703d548df069cb02aacea9efc3093ffdc3c4.tar.gz \
- https://github.com/golang/text/archive/v0.3.6/text-0.3.6.tar.gz \
+ https://github.com/golang/text/archive/v0.3.7/text-0.3.7.tar.gz \
https://github.com/googleapis/go-genproto/archive/24fa4b2/go-genproto-24fa4b261c55da65468f2abfdae2b024eef27dfb.tar.gz \
https://github.com/grpc/grpc-go/archive/v1.32.0/grpc-go-1.32.0.tar.gz \
- https://github.com/protocolbuffers/protobuf-go/archive/v1.26.0/protobuf-go-1.26.0.tar.gz"
-MD5SUM="6d8317d89e3928b9e6641035e7b95e57 \
+ https://github.com/BurntSushi/toml/archive/v0.4.1/toml-0.4.1.tar.gz \
+ https://github.com/google/go-cmp/archive/v0.5.6/go-cmp-0.5.6.tar.gz \
+ https://github.com/golang/mod/archive/v0.5.1/mod-0.5.1.tar.gz \
+ https://github.com/golang/tools/archive/v0.1.8/tools-0.1.8.tar.gz \
+ https://github.com/golang/xerrors/archive/5ec99f8/xerrors-5ec99f83aff198f5fbd629d6c8d8eb38a04218ca.tar.gz \
+ https://github.com/protocolbuffers/protobuf-go/archive/v1.26.0/protobuf-go-1.26.0.tar.gz \
+ https://github.com/dominikh/go-tools/archive/v0.2.2/go-tools-0.2.2.tar.gz"
+MD5SUM="95ff63a05327f6456da567604a6f40da \
e23b3240fc9e807fcffb97d12a433138 \
7bff4630d93dc4f9081b5dbc31067899 \
5e4827e740a060b8f97116955718de19 \
@@ -35,10 +41,16 @@ MD5SUM="6d8317d89e3928b9e6641035e7b95e57 \
fb384110572b31ee6e222cecbe610013 \
880d2f4ea4c362492ed4403ebfb0b9b2 \
8ed6c2ccd833013f26c102106405b444 \
- f406aa34e4555c0bac8c2f00f2ab729b \
+ efe2f974b42f7b0421edc8216aa7fef2 \
cbb310e9b9ede71e0ff38df5f5dc8268 \
44d6398e2ee17187a8143446db595522 \
- 2e97ffc1575be0c3c82702464a8d7e01"
+ eabff599b09ee87fcdb26c9daa1a0709 \
+ 27c9f186f83bfdd8d74091c7982ed289 \
+ 5e7a17c242b8c03d37717facd8cba925 \
+ 8874065b25ad08539a89ad27472c4537 \
+ f29763d058af4520d1cdc44cf31db4cf \
+ 2e97ffc1575be0c3c82702464a8d7e01 \
+ caaec41ee668f64032c6f350c1a36a2c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="protoc-gen-go-grpc python3-grpcio python3-pyinotify python3-slugify"
diff --git a/system/OpenSnitch/modules.txt b/system/OpenSnitch/modules.txt
index df3c15795f..1ca2e272c6 100644
--- a/system/OpenSnitch/modules.txt
+++ b/system/OpenSnitch/modules.txt
@@ -44,7 +44,7 @@ golang.org/x/net/context
# golang.org/x/sys v0.0.0-20211205182925-97ca703d548d
## explicit
golang.org/x/sys/unix
-# golang.org/x/text v0.3.6
+# golang.org/x/text v0.3.7
## explicit
golang.org/x/text/secure/bidirule
# google.golang.org/genproto v0.0.0-20190819201941-24fa4b261c55
@@ -57,6 +57,21 @@ google.golang.org/grpc/connectivity
google.golang.org/grpc/credentials
google.golang.org/grpc/encoding/gzip
google.golang.org/grpc/keepalive
+# github.com/BurntSushi/toml v0.4.1
+## explicit
+github.com/BurntSushi/toml
+# github.com/google/go-cmp v0.5.6
+## explicit
+github.com/google/go-cmp
+# golang.org/x/mod v0.5.1
+## explicit
+golang.org/x/mod
+# golang.org/x/tools v0.1.8
+## explicit
+golang.org/x/tools
+# golang.org/x/xerrors v0.0.0-20200804184101-5ec99f83aff1
+## explicit
+golang.org/x/xerrors
# google.golang.org/protobuf v1.26.0
## explicit
google.golang.org/protobuf/cmd/protoc-gen-go/internal_gengo
@@ -79,3 +94,6 @@ google.golang.org/protobuf/types/known/structpb
google.golang.org/protobuf/types/known/timestamppb
google.golang.org/protobuf/types/known/wrapperspb
google.golang.org/protobuf/types/pluginpb
+# honnef.co/go/tools v0.2.2
+## explicit
+honnef.co/go/tools
diff --git a/system/OpenSnitch/patches/modify-go.mod-file.patch b/system/OpenSnitch/patches/modify-go.mod-file.patch
deleted file mode 100644
index 7b16668a1e..0000000000
--- a/system/OpenSnitch/patches/modify-go.mod-file.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-# This patch was adapted from the one on Arch Linux:
-https://gitlab.archlinux.org/archlinux/packaging/packages/opensnitch/-/blob/main/add-go.sum-file.patch
---- a/daemon/go.mod
-+++ b/daemon/go.mod
-@@ -9,10 +9,16 @@ require (
- github.com/google/nftables v0.1.0
- github.com/google/uuid v1.3.0
- github.com/iovisor/gobpf v0.2.0
-+ github.com/josharian/native v0.0.0-20200817173448-b6b71def0850
-+ github.com/mdlayher/netlink v1.4.2
-+ github.com/mdlayher/socket v0.0.0-20211102153432-57e3fa563ecb
- github.com/varlink/go v0.4.0
- github.com/vishvananda/netlink v0.0.0-20210811191823-e1a867c6b452
-+ github.com/vishvananda/netns v0.0.0-20200728191858-db3c7e526aae
- golang.org/x/net v0.0.0-20211209124913-491a49abca63
- golang.org/x/sys v0.0.0-20211205182925-97ca703d548d
-+ golang.org/x/text v0.3.6
-+ google.golang.org/genproto v0.0.0-20190819201941-24fa4b261c55
- google.golang.org/grpc v1.32.0
-- google.golang.org/protobuf v1.26.0 // indirect
-+ google.golang.org/protobuf v1.26.0
- )