summaryrefslogtreecommitdiffstats
path: root/python/python3-httpx/python3-httpx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-httpx/python3-httpx.SlackBuild')
-rw-r--r--python/python3-httpx/python3-httpx.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/python/python3-httpx/python3-httpx.SlackBuild b/python/python3-httpx/python3-httpx.SlackBuild
index 6cb13328c1..d52671a71f 100644
--- a/python/python3-httpx/python3-httpx.SlackBuild
+++ b/python/python3-httpx/python3-httpx.SlackBuild
@@ -23,12 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220630 46and2: Updated version, updated DEP to add cli support.
+# 20221210 46and2: Updated version, changed build process and add deps.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-httpx
SRCNAM=$(echo $PRGNAM | sed 's/python3-//')
-VERSION=${VERSION:-0.23.0}
+VERSION=${VERSION:-0.23.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,11 +83,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-#remove upper version requirement from setup.py and httpx.egg-info/requires.txt
-/usr/bin/sed -i 's/,<[0-9].*\",$/\",/' setup.py
-/usr/bin/sed -i 's/<[0-9].*,//' httpx.egg-info/requires.txt
+#remove upper version requirement from pyproject.toml and PKG-INFO
+/usr/bin/sed -i 's/,<[0-9].*\",$/\",/' pyproject.toml
+/usr/bin/sed -i 's/<[0-9].*,//' PKG-INFO
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true