summaryrefslogtreecommitdiffstats
path: root/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild (renamed from python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild
index 9e00bce51e..62f4d4e7d5 100644
--- a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild
+++ b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild
@@ -22,14 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-wordpress-xmlrpc
+PRGNAM=python2-wordpress-xmlrpc
+SRCNAM=python-wordpress-xmlrpc
VERSION=${VERSION:-2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \