summaryrefslogtreecommitdiffstats
path: root/python/python-zipp/python-zipp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-zipp/python-zipp.SlackBuild')
-rw-r--r--python/python-zipp/python-zipp.SlackBuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/python/python-zipp/python-zipp.SlackBuild b/python/python-zipp/python-zipp.SlackBuild
index 79c3e5f2ac..4622558c71 100644
--- a/python/python-zipp/python-zipp.SlackBuild
+++ b/python/python-zipp/python-zipp.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-zipp
VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=zipp
@@ -71,6 +71,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s,^name =.*$,&\nversion = $VERSION," setup.cfg
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \