summaryrefslogtreecommitdiffstats
path: root/python/pyinotify/pyinotify.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--python/pyinotify/pyinotify.SlackBuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
index 5c5c293748..8aaa4145af 100644
--- a/python/pyinotify/pyinotify.SlackBuild
+++ b/python/pyinotify/pyinotify.SlackBuild
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,10 +66,7 @@ find -L . \
sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true