summaryrefslogtreecommitdiffstats
path: root/python/pyflakes/pyflakes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--python/pyflakes/pyflakes.SlackBuild (renamed from development/pyflakes/pyflakes.SlackBuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/development/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
index 01284f8684..7c530c1ee7 100644
--- a/development/pyflakes/pyflakes.SlackBuild
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyflakes
-# Copyright 2010 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyflakes
-VERSION=${VERSION:-0.4.0}
+VERSION=${VERSION:-0.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -53,12 +51,15 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python setup.py build
python setup.py install --prefix=/usr/ --root=$PKG
-# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild