summaryrefslogtreecommitdiffstats
path: root/python/ptyprocess/ptyprocess.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ptyprocess/ptyprocess.SlackBuild')
-rw-r--r--python/ptyprocess/ptyprocess.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/ptyprocess/ptyprocess.SlackBuild b/python/ptyprocess/ptyprocess.SlackBuild
index df1ddda2d5..1a6b6ecac1 100644
--- a/python/ptyprocess/ptyprocess.SlackBuild
+++ b/python/ptyprocess/ptyprocess.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ptyprocess
-# Copyright 2016-2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ptyprocess
-VERSION=${VERSION:-0.5.2}
+VERSION=${VERSION:-0.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true