summaryrefslogtreecommitdiffstats
path: root/python/entrypoints/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/entrypoints/setup.py')
-rw-r--r--python/entrypoints/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/python/entrypoints/setup.py b/python/entrypoints/setup.py
new file mode 100644
index 0000000000..e278244224
--- /dev/null
+++ b/python/entrypoints/setup.py
@@ -0,0 +1,13 @@
+
+from setuptools import setup, find_packages
+
+setup(
+ name='entrypoints',
+ version='0.3',
+ description='Discover and load entry points from installed packages',
+ url='https://github.com/takluyver/entrypoints',
+ author='https://github.com/takluyver',
+ license='MIT',
+ long_description='The entrypoints module contains functions to find and load entry points, a way for Python packages to advertise objects.',
+ py_modules=['entrypoints']
+)