summaryrefslogtreecommitdiffstats
path: root/python/cocos2d/cocos2d.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cocos2d/cocos2d.SlackBuild')
-rw-r--r--python/cocos2d/cocos2d.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/cocos2d/cocos2d.SlackBuild b/python/cocos2d/cocos2d.SlackBuild
index 64bd6648fa..802409e2d0 100644
--- a/python/cocos2d/cocos2d.SlackBuild
+++ b/python/cocos2d/cocos2d.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for Cocos2d
-# Copyright 2017 Klaatu, Wellington NZ.
+# Copyright 2019 Klaatu | Lawrence NZ | klaatu@member.fsf.org
# GNU All-Permissive License
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -10,10 +10,11 @@
PRGNAM=cocos2d
SRCNAM=cocos
-VERSION=${VERSION:-0.6.4}
+VERSION=${VERSION:-0.6.7}
SRCVER=release-$VERSION
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PYTHON=${PYTHON:-python}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -43,7 +44,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true