summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/pdnsd/README13
-rw-r--r--network/pdnsd/doinst.sh23
-rw-r--r--network/pdnsd/pdnsd.SlackBuild106
-rw-r--r--network/pdnsd/pdnsd.info10
-rw-r--r--network/pdnsd/rc.pdnsd78
-rw-r--r--network/pdnsd/slack-desc19
6 files changed, 0 insertions, 249 deletions
diff --git a/network/pdnsd/README b/network/pdnsd/README
deleted file mode 100644
index f11b7d39ea..0000000000
--- a/network/pdnsd/README
+++ /dev/null
@@ -1,13 +0,0 @@
-pdnsd is a proxy DNS server with permanent caching (the cache contents are
-written to hard disk on exit) that is designed to cope with unreachable or
-down DNS servers (e.g., in dial-in networking).
-
-Add this to /etc/rc.d/rc.local:
-if [ -x /etc/rc.d/rc.pdnsd ]; then
- /etc/rc.d/rc.pdnsd start
-fi
-
-Add this to /etc/rc.d/rc.local_shutdown
-if [ -x /etc/rc.d/rc.pdnsd ]; then
- /etc/rc.d/rc.pdnsd stop
-fi
diff --git a/network/pdnsd/doinst.sh b/network/pdnsd/doinst.sh
deleted file mode 100644
index b09bee1dad..0000000000
--- a/network/pdnsd/doinst.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.pdnsd.new:
-if [ -e etc/rc.d/rc.pdnsd ]; then
- cp -a etc/rc.d/rc.pdnsd etc/rc.d/rc.pdnsd.new.incoming
- cat etc/rc.d/rc.pdnsd.new > etc/rc.d/rc.pdnsd.new.incoming
- mv etc/rc.d/rc.pdnsd.new.incoming etc/rc.d/rc.pdnsd.new
-fi
-
-config etc/rc.d/rc.pdnsd.new
-config etc/pdnsd.conf.new
-
diff --git a/network/pdnsd/pdnsd.SlackBuild b/network/pdnsd/pdnsd.SlackBuild
deleted file mode 100644
index bf8e31e431..0000000000
--- a/network/pdnsd/pdnsd.SlackBuild
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pdnsd
-
-# Written by André Geraldo Vieira <andre.geraldo@gmail.com>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pdnsd
-VERSION=${VERSION:-1.2.7}
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-par.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-ipv6 \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-# Install an init script
-mkdir -p $PKG/etc/rc.d/
-cat $CWD/rc.pdnsd > $PKG/etc/rc.d/rc.pdnsd.new
-chmod 0755 $PKG/etc/rc.d/rc.pdnsd.new
-
-# Rename pdnsd.conf.sample to pdnsd.conf.new
-mv $PKG/etc/pdnsd.conf.sample $PKG/etc/pdnsd.conf.new
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog* COPYING* INSTALL NEWS PKGBUILD README* THANKS TODO \
- version doc/html doc/txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/pdnsd/pdnsd.info b/network/pdnsd/pdnsd.info
deleted file mode 100644
index a4f6844138..0000000000
--- a/network/pdnsd/pdnsd.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pdnsd"
-VERSION="1.2.7"
-HOMEPAGE="http://members.home.nl/p.a.rombouts/pdnsd/"
-DOWNLOAD="http://members.home.nl/p.a.rombouts/pdnsd/releases/pdnsd-1.2.7-par.tar.gz"
-MD5SUM="114b3b21b09b43cbfcccdde726b84c12"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="André Geraldo Vieira"
-EMAIL="andre.geraldo@gmail.com"
diff --git a/network/pdnsd/rc.pdnsd b/network/pdnsd/rc.pdnsd
deleted file mode 100644
index 64115e1cb5..0000000000
--- a/network/pdnsd/rc.pdnsd
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-#
-# /etc/rc.d/rc.pdnsd
-#
-# Starts the Proxy DNS Daemon
-#
-# description: Proxy DNS Daemon
-# processname: pdnsd
-# config: /etc/pdnsd.conf
-# distribution: Slackware
-# author: André Geraldo Vieira <andre.geraldo@gmail.com>
-#
-# Additional info:
-# 1) put these lines in the /etc/rc.d/rc.local:
-# if [ -x /etc/rc.d/rc.pdnsd ]; then
-# /etc/rc.d/rc.pdnsd start
-# fi
-#
-# 2) put these lines in the /etc/rc.d/rc.local_shutdown:
-# if [ -x /etc/rc.d/rc.pdnsd ]; then
-# /etc/rc.d/rc.pdnsd stop
-# fi
-
-start() {
- if ! [ -r /var/run/pdnsd.pid ]; then
- echo -n 'Starting pdnsd...'
- /usr/sbin/pdnsd -d -p /var/run/pdnsd.pid
- echo 'OK'
- else
- echo 'The PDNSD is already running!'
- fi
-}
-
-stop() {
- if [ -r /var/run/pdnsd.pid ]; then
- echo -n "Shutting down pdnsd... "
- kill -15 `cat /var/run/pdnsd.pid` && rm -f /var/run/pdnsd.pid 2> /dev/null
- echo ' OK'
- else
- echo 'The PDNSD already stopped!'
- fi
-}
-
-restart() {
- stop
- sleep 3
- start
-}
-
-status() {
- if [ -r /var/run/pdnsd.pid ]; then
- pid=`cat /var/run/pdnsd.pid`
- echo "PDNSD (pid $pid) is running."
- else
- echo 'PDNSD is stopped.'
- fi
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- reload|restart)
- restart
- ;;
- status)
- status
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|reload|status}"
- exit 1
- ;;
-esac
-exit 0
-#EOF
diff --git a/network/pdnsd/slack-desc b/network/pdnsd/slack-desc
deleted file mode 100644
index f9b33ef431..0000000000
--- a/network/pdnsd/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pdnsd: pdnsd (proxy dns server)
-pdnsd:
-pdnsd: pdnsd is a proxy DNS server with permanent caching (the cache contents
-pdnsd: are written to hard disk on exit) that is designed to cope with
-pdnsd: unreachable or down DNS servers (for example in dial-in networking).
-pdnsd: Since version 1.1.0, pdnsd supports negative caching.
-pdnsd:
-pdnsd: pdnsd is licensed under the GNU General Public License (GPL).
-pdnsd:
-pdnsd:
-pdnsd: