summaryrefslogtreecommitdiffstats
path: root/games/pioneer/pioneer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/pioneer/pioneer.SlackBuild')
-rw-r--r--games/pioneer/pioneer.SlackBuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games/pioneer/pioneer.SlackBuild b/games/pioneer/pioneer.SlackBuild
index 4ed508daef..d7d399338f 100644
--- a/games/pioneer/pioneer.SlackBuild
+++ b/games/pioneer/pioneer.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pioneer
-VERSION=${VERSION:-20240203}
+VERSION=${VERSION:-20240314}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,16 +83,14 @@ else
RELEASE=Release
fi
+# Fix save compatibility (#5798).
+patch -p0 < $CWD/save-compat.diff
+
GLEW=OFF
LUA=OFF
pkg-config --exists glew && GLEW=ON
-
-# 20210214 bkw: cmake can't easily be told to ignore lua 5.1 on a
-# system where both 5.1 and 5.2 are installed. In that case, we'll
-# use the bundled lua source. Note that there's no problem with 5.3,
-# as cmake seems to search for them in order.
-pkg-config --exists lua5.2 && ! pkg-config --exists lua && LUA=ON
+pkg-config --exists lua5.2 && LUA=ON
# 20210214 bkw: prevent the build from writing to /root/, without
# breaking ccache if it's in use.
@@ -114,9 +112,10 @@ cd build
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_BINDIR=games \
- -DCMAKE_INSTALL_DATADIR=/usr/share/games \
+ -DCMAKE_INSTALL_DATADIR=share/games \
-DUSE_SYSTEM_LIBGLEW=$GLEW \
-DUSE_SYSTEM_LIBLUA=$LUA \
+ -DFMT_INSTALL=OFF \
-DPROJECT_VERSION_INFO="$INFOSTRING" \
-DCMAKE_BUILD_TYPE=$RELEASE ..
make
@@ -133,12 +132,13 @@ fi
# supposed to be and install an SVG icon.
rm -rf $PKG/usr/share/games/$PRGNAM/{licenses,*txt,*md}
mv $PKG/usr/share/games/{icons,applications,metainfo} $PKG/usr/share
+sed -i 's|Exec=|Exec=/usr/|g' $PKG/usr/share/applications/net.pioneerspacesim.Pioneer.desktop
mkdir -p $PKG/usr/share/icons/hicolor/scalable/apps
install -m 0644 application-icon/badge-full.svg \
$PKG/usr/share/icons/hicolor/scalable/apps/net.pioneerspacesim.Pioneer.svg
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a licenses *.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a licenses *.txt README.md NEWS.md $PKG/usr/doc/$PRGNAM-$VERSION
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/{CMakeLists,SAVEBUMP}.txt
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild