summaryrefslogtreecommitdiffstats
path: root/games/pcsx2/pcsx2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--games/pcsx2/pcsx2.SlackBuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/games/pcsx2/pcsx2.SlackBuild b/games/pcsx2/pcsx2.SlackBuild
index df919ac0bb..2f5096784e 100644
--- a/games/pcsx2/pcsx2.SlackBuild
+++ b/games/pcsx2/pcsx2.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pcsx2
-VERSION=${VERSION:-2018.05.16_290397d}
+VERSION=${VERSION:-2018.12.11_0e43803}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -92,9 +92,15 @@ fi
[ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
+# Handle this in doinst.sh instead
+# https://github.com/PCSX2/pcsx2/issues/2699
+sed -i '/setcap/d' pcsx2/CMakeLists.txt
+
# Use a font included with Slackware
# osd error: 'Failed to init the freetype face'
-zcat $CWD/osd_font.diff.gz | patch -p1
+sed -i \
+ 's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
+ plugins/GSdx/GSdx.cpp
mkdir -p build
cd build
@@ -121,8 +127,8 @@ cd build
cd ..
if [ "$DEBUG" = 0 ]; then
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
fi
find $PKG/usr/man -type f -exec gzip -9 {} \;