summaryrefslogtreecommitdiffstats
path: root/games/hnefatafl/hnefatafl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/hnefatafl/hnefatafl.SlackBuild')
-rw-r--r--games/hnefatafl/hnefatafl.SlackBuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/games/hnefatafl/hnefatafl.SlackBuild b/games/hnefatafl/hnefatafl.SlackBuild
index f480eff456..3e0af446a3 100644
--- a/games/hnefatafl/hnefatafl.SlackBuild
+++ b/games/hnefatafl/hnefatafl.SlackBuild
@@ -2,14 +2,14 @@
# Slackware 14.0 build script for HNEFATAFL
-# Copyright 2013 Alexander Söderlund, Sweden. Revised 2013-07-09.
+# Copyright 2013 Alexander Söderlund, Sweden. Revised 2013-09-20.
#
# Script license: CC0, see:
# http://creativecommons.org/publicdomain/zero/1.0/
# http://creativecommons.org/publicdomain/zero/1.0/legalcode
PRGNAM=hnefatafl
-VERSION=${VERSION:-130527}
+VERSION=${VERSION:-130920}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -28,16 +28,16 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ SLKCFLAGS="-O3 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ SLKCFLAGS="-O3 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-O3 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
+ SLKCFLAGS="-O3"
LIBDIRSUFFIX=""
fi
@@ -57,18 +57,12 @@ find . \
-exec chmod 644 {} \;
if [ ! "${LINK_XLIB:-YES}" = "YES" ]; then
- patch -p1 < $CWD/no-link-xlib.diff
+ patch -p1 config.mk $CWD/no-link-xlib.diff
fi
# See config.mk for available LANGUAGE ISO 639-2 codes.
-# CFLAGS_WARN, which are optional anyway, cause warnings to be treated as
-# errors, which make the no-x11 build error out
-# CFLAGS_OPT_LVL defaults to -Ofast, but we want the -O2 from SLKCFLAGS
-# to be used
make \
- CFLAGS_WARN="" \
- CFLAGS_OPT_LVL="" \
- CFLAGS_OPT_ARC="$SLKCFLAGS" \
+ CFLAGS_OPT="$SLKCFLAGS" \
LANGUAGE="${LANGUAGE:-eng}" \
PREFIX="/usr" \
PREFIX_X11_LIB="/usr/lib${LIBDIRSUFFIX}"
@@ -76,7 +70,7 @@ make \
make install \
LANGUAGE="${LANGUAGE:-eng}" \
PREFIX="${PKG}/usr" \
- PREFIX_DATA_RULES_CONF="/usr/share/games/${PRGNAM}/rules"
+ PREFIX_DATA_RULES_CONF="/usr/share/games/${PRGNAM}/rules"
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true