summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild b/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
index 6687555ef5..b0f3a0de1d 100644
--- a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
+++ b/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-nbconvert
-VERSION=${VERSION:-7.16.0}
+VERSION=${VERSION:-7.16.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -50,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,7 +67,7 @@ find -L . \
# Build jupyter-nbconvert offline
# Code taken from Gentoo science project:
-# https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-python/nbconvert/nbconvert-7.13.0.ebuild
+# https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-python/nbconvert/nbconvert-7.16.1.ebuild
sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' -i hatch_build.py
python3 -m build --no-isolation