summaryrefslogtreecommitdiffstats
path: root/development/codespell/codespell.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/codespell/codespell.SlackBuild')
-rw-r--r--development/codespell/codespell.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index b74e7036bf..134b0d7f93 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -6,6 +6,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230115 bkw: update for 2.2.1, not the latest (see README).
# 20210829 bkw:
# - update for 2.1.0.
# - use python3 by default. add PYVER var to force building with 2,
@@ -15,7 +16,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codespell
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-2.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,14 +64,16 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-python${PYVER:-3} setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
-make $PRGNAM.1
+# upstream removed the man page. including a copy of the 2.1.0 man page,
+# which seems to still apply to 2.2.1 (all the options are the same).
mkdir -p $PKG/usr/man/man1
-gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* COPYING example $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install