summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-hello/nwg-hello.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/nwg-hello/nwg-hello.SlackBuild')
-rw-r--r--desktop/nwg-hello/nwg-hello.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/desktop/nwg-hello/nwg-hello.SlackBuild b/desktop/nwg-hello/nwg-hello.SlackBuild
index 8127f97d6a..21740bf044 100644
--- a/desktop/nwg-hello/nwg-hello.SlackBuild
+++ b/desktop/nwg-hello/nwg-hello.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=nwg-hello
-VERSION=${VERSION:-0.2.0}
+VERSION=${VERSION:-0.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -85,6 +85,8 @@ find -L . \
# fix default sway conf
sed -i -e 's,systemctl,loginctl,g' sway-config
+ python3 -m build --wheel --no-isolation
+
install -Dm0644 -t $PKG/etc/nwg-hello/ nwg-hello-default.json
install -Dm0644 -t $PKG/etc/nwg-hello/ nwg-hello-default.css
install -Dm0644 -t $PKG/etc/nwg-hello/ hyprland.conf
@@ -96,11 +98,11 @@ sed -i -e 's,systemctl,loginctl,g' sway-config
install -d $PKG/var/cache/nwg-hello
install -Dm0644 -t $PKG/var/cache/nwg-hello cache.json -o greeter
- python3 setup.py install --root="$PKG" --optimize=1
+ python3 -m installer --destdir=$PKG dist/*.whl
# install default config file into package so things work
# auto-magically upon install
-install -Dm0644 -t $PKG/etc/nwg-hello/nwg-hello.json $CWD/nwg-hello.json
+install -Dm0644 -t $PKG/etc/nwg-hello/ $CWD/nwg-hello.json
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true