summaryrefslogtreecommitdiffstats
path: root/audio/yabridge/yabridge.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/yabridge/yabridge.SlackBuild')
-rw-r--r--audio/yabridge/yabridge.SlackBuild76
1 files changed, 51 insertions, 25 deletions
diff --git a/audio/yabridge/yabridge.SlackBuild b/audio/yabridge/yabridge.SlackBuild
index 1193329747..721c1ff54d 100644
--- a/audio/yabridge/yabridge.SlackBuild
+++ b/audio/yabridge/yabridge.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yabridge
-VERSION=${VERSION:-5.0.1}
+VERSION=${VERSION:-5.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -56,6 +56,8 @@ WINE_IN_PATH=$?
which wine64 &>/dev/null
WINE64_IN_PATH=$?
+WINE_VERSION=$(wine --version | grep --only-matching -E '[0-9]+\.[0-9]+' | head -n1)
+
if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
if (($WINE_IN_PATH)); then
echo "This script look for wine in PATH and needs it for compiling and using yabridge on i586"
@@ -96,31 +98,55 @@ sed -i "s|bitsery_dep = dependency('bitsery', 'Bitsery', version : '>=5.2.0')|bi
mkdir subprojects/vst3
cp -a /usr/include/vst3sdk/* subprojects/vst3/
cp yabridge-html-docs-plus-build-files-$VERSION/meson.build subprojects/vst3
-
-if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
- meson setup \
- build \
- --cross-file=cross-wine.conf \
- --buildtype=release \
- --unity=on \
- --unity-size=1000 \
- --wrap-mode=nodownload \
- -Dbitbridge=true \
- -Dsystem-asio=true \
- -Dbuild.cpp_args='-m32' \
- -Dbuild.cpp_link_args='-m32'
-elif [ "$ARCH" = "x86_64" ]; then
- meson setup \
- build \
- --cross-file=cross-wine.conf \
- --buildtype=release \
- --unity=on \
- --unity-size=1000 \
- --wrap-mode=nodownload \
- -Dbitbridge=true \
- -Dsystem-asio=true
+if (( $(echo "$WINE_VERSION >= 7.21" |bc -l) )) && (( $(echo "$WINE_VERSION < 7.23" |bc -l) ));
+then
+ if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true \
+ -Dbuild.cpp_args='-m32' \
+ -Dbuild.cpp_link_args='-m32'
+ elif [ "$ARCH" = "x86_64" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true
+ else
+ echo "Unsupported architecture"
+ fi
else
- echo "Unsupported architecture"
+ if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --unity=on \
+ --unity-size=1000 \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true \
+ -Dbuild.cpp_args='-m32' \
+ -Dbuild.cpp_link_args='-m32'
+ elif [ "$ARCH" = "x86_64" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --unity=on \
+ --unity-size=1000 \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true
+ else
+ echo "Unsupported architecture"
+ fi
fi
# Build yabridge